Very low put ratio on new nodes

I setup a bunch of nodes on kimsufi KS3 servers at the start of February to see the affect on utilization that would occur from having nodes on the same /24 subnet.

I have 8 of those servers running a single storage node each on a 2TB hard drive.
4 have different subnets and other 4 have paired subnets (2 on one subnet, 2 on another) and in same rack.

The problem I am having is my putratio (upload success ratio?) is very low on all nodes. Is this because they are not vetted yet or because the Atom processors are too slow? Currently highest is about 6%!



1 Like

docker ot gui nodes?

Docker nodes on debian 10, internal drives

I’m impressed with you setup! The thought of setting something up like that is way over my head.

BUT to your question, I’d say part of it is the nodes are still being vetted so getting little upload traffic is fairly normal. Also, it appears that the current version has some issues with under-reporting successful puts. There are numerous posts about this all over this forum.



here’s the post about the next software version release, which should help resolve this issue.

Oh, I forgot that the putratio number I am looking at comes from logs! That would explain it then.

Hopefully the new version makes the numbers better.

I also run 25TB windows node in Helsinki which has about 4TB stored so far. Soon to have another few 8TB nodes in UK but will bring those on slowly as they are all in the same server.

Looks like they are starting to get vetted now, big increase in bandwidth.

And the ratio is going up now on several nodes.

1 Like

What do the numbers look like for profitability? I spun up some KS3 servers for other purposes and decided to run Storj nodes while I have them. I maxed out each node at 1.5TB and just downloaded all the data to my home server to run alongside my main node at home.

Unless you’re depending on a bunch of egress topic, you’d never make up enough to cover the cost of the servers.