"Wait until container restarts fail"

I got this after a manual update :

C:\Users\UserX> docker exec -it storagenode /app/dashboard.sh
Error response from daemon: Container 20b60784aaecc2313ac298107b6ea1b9acf72c6edeb60bbfc759286a1174d557 is restarting, wait until the container is running
PS C:\Users\UserX>

I have looked at some other threads about the mounting but can’t find anything strange what I think there… so please help!

I tried to rm the image and pulled new and editing the command but no sucess.

Sometimes after a storagenode rm when you restart the node it checks the files and it can take some minuters if you have alot of data. But after a while you can start the dashboard

It has been offline over 2-3 days now.

It will not start, I haven’t made any changes except pulled the new version

Have you tried stopping the container, removing it, restart the machine, then run your docker run command?

I had this issue on my pi and a reboot seemed to fix it. Hope this helps!

Yes at least 3 times now… No fix yet… Im on windows 10 with docker dekstop and have been running with out problem before the new image update… Can I delete something and “start over” ?

Here’s from the log :

2019-12-20T07:52:24.444Z INFO Configuration loaded from: /app/config/config.yaml
2019-12-20T07:52:24.472Z INFO Operator email: ***
2019-12-20T07:52:24.473Z INFO operator wallet: ***
2019-12-20T07:52:25.609Z INFO version running on version v0.28.2
2019-12-20T07:52:25.666Z INFO db.migration.27 Add index archived_at to ordersDB
2019-12-20T07:52:25.795Z FATAL Unrecoverable error {“error”: “Error creating tables for master database on storagenode: migrate: database disk image is malformed\n\tstorj.io/storj/private/migrate.(*Migration).Run:166\n\tstorj.io/storj/storagenode/storagenodedb.(*DB).CreateTables:289\n\tmain.cmdRun:186\n\tstorj.io/storj/pkg/process.cleanup.func1.2:278\n\tstorj.io/storj/pkg/process.cleanup.func1:296\n\tgithub.com/spf13/cobra.(*Command).execute:826\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:914\n\tgithub.com/spf13/cobra.(*Command).Execute:864\n\tstorj.io/storj/pkg/process.Exec:74\n\tmain.main:315\n\truntime.main:203”, “errorVerbose”: “Error creating tables for master database on storagenode: migrate: database disk image is malformed\n\tstorj.io/storj/private/migrate.(*Migration).Run:166\n\tstorj.io/storj/storagenode/storagenodedb.(*DB).CreateTables:289\n\tmain.cmdRun:186\n\tstorj.io/storj/pkg/process.cleanup.func1.2:278\n\tstorj.io/storj/pkg/process.cleanup.func1:296\n\tgithub.com/spf13/cobra.(*Command).execute:826\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:914\n\tgithub.com/spf13/cobra.(*Command).Execute:864\n\tstorj.io/storj/pkg/process.Exec:74\n\tmain.main:315\n\truntime.main:203\n\tmain.cmdRun:188\n\tstorj.io/storj/pkg/process.cleanup.func1.2:278\n\tstorj.io/storj/pkg/process.cleanup.func1:296\n\tgithub.com/spf13/cobra.(*Command).execute:826\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:914\n\tgithub.com/spf13/cobra.(*Command).Execute:864\n\tstorj.io/storj/pkg/process.Exec:74\n\tmain.main:315\n\truntime.main:203”}

How do I repair the “master database” ?

Thank you so much! My “orders.db” was corrupted , now online again :grin: