1.42.2 impossible to start service

my main node went offline few hours ago, tried to start the service again but it get stucks while starting, cannot even stop it with cmd “net stop storagenode”, it says “service starting, try a bit later”

tried to downgrade it to 1.40.4 (just by copy pasting & renaming the storagenode.old.v1.40.4.exe that was in the storj program files folder), did the latest updates of w10 but it’s still getting stuck when trying to start the service.
tried to reinstall via the latest github release but the installer got stuck at “starting service”.

my 2nd node (that didn’t automatically updated because i’m using Storj Node Toolbox) is still fine and running 1.40.2.

disk is perfectly fine.

I have no idea about what else to try/do, any help would be welcome!

1 Like

ty, didn’t see this.

replaced the actual .exe (1.42.2) by an old version that was in the storj program files folder (1.40.4) AND stopped the storj updater service, then ONLY started the storj node service and everything went good, my node is back online while they’re working on a fix.

1 Like

Same issue, glad you figured it out before I made a post! Thanks bud.

1 Like

Thats not a solution :slight_smile:
Can we fully sort this out please? :stuck_out_tongue:

There was a point release made to v1.42.3. Could you please test that?

1 Like

it also not working, so wait for solution, team is working.

1 Like