Access cli bucket from web

Hey guys.

I’m trying to access a file uploaded by cli in the web dashboard, but I can’t see it. I can see the bucket in the cli and upload completely fine. The bucket also shows up in the web dashboard, but no files are shown. Is it even possible to acces cli uploaded files from web? Am I missing something?

Have a great day!

Edit: I am using the same passphrase.

If you are seeing the bucket, but not seeing any files – you are not using the same passphrase.


This is a crypto algorithm, if provided encryption phrase doesn’t match a previously used - your objects is impossible to decrypt, thus they will be hided.
So you need to use exactly the same encryption phrase (include spaces), as used during upload.

Alright, I tried multiple things:

  1. Copying the passphrase, pasting it in cleartext, copying it again, pasting in in the cli while setting uplink up.
  2. Same as 1. but instead of right clicking I used CTRL+V
  3. Typing the passphrase manually, in cli and the web dashboard.
  4. Setting up uplink cli on 2 different machines, local and remote. Using the same password on both. That works, I could download my testfile on my local machine using cli after uploading it using cli on the remote one. So passwords must be the same. Entering the same password in the web dashboard still doesn’t show me the file.

No results at all. It doesn’t even show me that there is an object in the bucket in the web dashboard. When uploading a file in the web dashboard and accessing it from the cli, I can see it, but it’s encrypted. I know this means I used another passphrase, but I literally typed it in myself, no copying or anything.

I’m usually good with stuff like that, this is why this drives me insane.

Edit: I tried using the cli on another machine with the exact same password I used in step 4. That works. When I try to access the file in the web dashboard, with EXACTLY the same password that works on 3 cli instances on 3 physically different machines I just get locked objects.

The web UI will not show an object, if it cannot decrypt it with the provided encryption phrase.

Is it possible that you use some password manager extension in your browser and it replaces what you have typed to stored password? If so, please try to disable this extension (or configure it to do not activate on the satellite UI site) or use a different browser.
You may also try to clear cache and cookies for this site.