Access to Storj Gateway from an IOS App

I have tried to access a bucket using S3 on Storj using an IOS APP , but I always get a bucket cannot be reached error. I tried accessing it from my desktop, and I can get to it with no issues using the same credentials and end point. Do i need to do something different from IOs? Is there a restriction on IOS to execute direct access to S3 ?

Welcome to the Forum @asharma !
I have forwarded your question to the team and someone will return with assistance.

These restrictions likely in the used app. Did you try to contact their authors? Perhaps they do not support a custom endpoint and always goes to the Amazon?
By the way, please try to provide an endpoint as or the opposite - as

Which iOS app? If this one ‎S3 Files - Bucket Storage on the App Store — you need to provide a region, e.g. us-east-1. It works fine.

1 Like

The app I am using is Obsidian, and the plugin to access cloud data is remotely sync . I am using the gateway as and the region as US1. tried other regions. but always get S3 bucket could not be reached error. For the same plugin, when i use it from PC with same credentials, have no issue connecting to the storj bucket

tried both ways, no luck

Then I guess you need to contact authors of this plugin, seems they have a bug.
By the way, does it allow to do not provide a region?
What else parameters they have?

Yes the region is mandatory. Or it gives an error. Along with those I have to provide the secrete and password.

Is the region preconfigured or you may provide your own?
If you can provide a custom region you may try to specify it as gateway and set the endpoint to Some apps just combine the bucket name with the region and the endpoint.
The other workaround is to enable a path style, if it has this option.
Can you show a screenshot of the configuration window?