Accessing dashboard

Hello every one,

I just finish to setup my node on my windows 10 computer. but i cannot find how to acces dashboard and so i am not sure if every thing is working properly.
I followed the instructions in the documentation to setup my node.
to first run my node I ran the command line :
docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967 -p -e WALLET=“0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX” -e EMAIL="" -e ADDRESS=“” -e STORAGE=“2TB” --mount type=bind,source="",destination=/app/identity --mount type=bind,source="",destination=/app/config --name storagenode storjlabs/storagenode:latest

it seems to work properly since i didn’t received any error messages. and the command “docker ps a-” tells me the node was created.

But here is my problem i cannot acces dashboard. so i tried to follow the instructions in the documentation but replacing “-p” by “-p 14002:14002” returns me the following error message :
" docker: Error response from daemon: Conflict. The container name “/storagenode” is already in use by container “24d1a9e0f4d9652d1fd095d297601f967a986ba8d8a618fcdce910fe3fe3c6c6”. You have to remove (or rename) that container to be able to reuse that name.

See ‘docker run --help’."

how can id o to have a look to my node statistiques ?

thank you for your help.

With this from your local machine (the one running the node) you should be able to point your browser to and see the dashboard. If you are looking to access the dashboard from a different device on your network, which is what it appears you are doing by removing the localhost IP of from the Docker parameters…

You are on the right path but as Docker warns you need to first remove the already configured container. You’ll want to first stop the container (see documentation) and then remove it. Off the top of my head I think the command would be
docker rm storagenode
since “storagenode” is what you named the container in your docker run command. Note this only removes the configured Docker container; your node that you created with the Docker setup command will still exist. Once you have the container removed you can then re-run the docker run command with new parameters as needed, including the omission of from the dashboard port configuration. You should then be able to access your dashboard from other machines in your network via http://nodecomputersIP:14002.

1 Like

Only in case of -p 14002:14002. With -p only on local machine by http://localhost:14002

'Twas noted, but I’ve clarified in my original post via edit.

And @gandalf, I’ve confirmed the Docker command to remove your container is as I mentioned above.

1 Like

Ok, thank you craig and alexey ! i will try to remove the container and make a new one. I keep you in touch of my advancement.
for now i use -p but i cannot access to dashboard even from my host device…

Please, give me 20 last lines from the logs:

docker logs --tail 20 storagenode

here you got it.

i stopped my node and removed my cotainer. then i started it again with :
docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967 -p 14002:14002 -e WALLET=“0xmywallet” -e EMAIL=“” -e ADDRESS=“” -e STORAGE=“3,63TB” --mount type=bind,source=“C:\path to node”,destination=/app/identity --mount type=bind,source=“D:\mydir”,destination=/app/config --name storagenode storjlabs/storagenode:latest

but i still can’t access on any device. i guess i am missing something

Please, make sure that you used a Notepad++ to form the command, it should have only straight quotes ", the curly ones are not allowed in the shell, you also should use a double dash -- instead of hyphen. The amount of storage should have a decimal point instead of comma.

1 Like

Thank you alexey !
it appears it was because i edited my command line without notepad++, i did so even if notepad++ is said to be good in the doc because my device does’t have enough free space to install anything.
so i installed notepad++ it in another computer and it is OK i can access to dash board (at least with my host device i don’t have time to test others right now).

dashboard says my node is online :slight_smile: it still help no one to store files for the moment but it is just online from 10minutes ago so it is completely normal !!

thank you very much !

1 Like