Almost there with the node

Hi! I finally got al that i needed to setup my node and every thing goes as planed until the last step when the throws an error at me:
image
The number in powershell that i got are 2 and 3, done the port forwarding, i do not know what else to do. Need help.
Best regards

Heyo, have you made sure to actually launch the installer as a full administrator with all necessary permissions?

Please show the last 20 lines from your logs: How do I check my logs? - Storj Node Operator Docs

the only line from the log is this:
2023-02-24T08:16:20.976+0100 INFO Anonymized tracing enabled {“Process”: “storagenode”}

Just the one line, or that one line repeated?

What version of Windows are you running?

Can you open services.msc as Administrator and then check if the ‘Storj V3 Storage Node’ and ‘Storj V3 Storage Node Updater’ are both present and running.

If not present then the install didn’t work.
If present but ‘Stopped’ try to Start both. Does it run or error? Check the log in either case.

it is only one line and none of the listed is running in services.msc
windows 10 pro version (i use atlas os) os build: 19042.631

If present but ‘Stopped’ try to Start both. Does it run or error? Check the log in either case.

they are not present

Reboot the machine and try to install again as Administrator.

tried that already, with no luck any other ideas?

The more information you provide the easier it is for us to diagnose the problem.

The same error shows during the setup?

Is the log file still one line?

How many times have you tried to install?

Are there files in C:\Program Files\Storj\Storage Node? Which files?

image
these are the files when the error popup
and when i close the installer then there are just two
image
still one line in log
tried installing it about 20 times

Ok, uninstall the storagenode software and remove the folder "c:\Program Files\Storj".
Please enable firewall if you have disabled it - it’s a mandatory service, after that try to install again.

hi same problem will not start services and only one log line

Did you “optimize” your Windows system by disabling/removing “unneeded” services, like Windows Firewall, dnscache, some network services?
Did you install storagenode to the default location ("c:\Program Files\Storj") or selected another one?

Please open Event Viewer and search for error, related to install of storagenode and post this error here.

did it, the problem was in the version of windows 10 (atlas os ) i had did the clean install and it finally worked, thanks for help everybody

1 Like