As a Rookie I want my Newbie StorJ RPi3 Storagenode to be online again so that I can tell everyone I am doing Blockchain stuff

Hi everbody and have a good day,

as a Rookie I want my Newbie StorJ RPi3 Storagenode to be online again so that I can tell everyone I am doing Blockchain stuff.


  • third day on the whole topic
  • no RaspberryPi skills
  • nor command line skills
  • nor other relevant real skills
  • nor know-how for topics like that in general
  • but I can use Google and follow the pro advise of others
  • and I learned that I most often forget that “sudo” thing
  • and I really hate that right click copy in the CLI stuff thingy +args+

Problem background?

  • Made a node running yesterday in the evening after 4 hours following this tut here:
  • Used an old Raspberry 3 Model B sitting around for years - testingwise sufficient - check
  • Used putty to generate keys - check
  • Used desktop windows pc to create and sign identity - check
  • Used WinSCP to move them to the Pi - check
  • Configured dhcp in RPi3 to static
  • Used NoIP account and did the tuts in the above tut - DUC and stuff
  • Used yougetsignal to check portsignal - showed closed - checked everything, but then ignored it, because read infos similar to “not possible from a station within the Local Area Network”, therefore I skipped it.
  • Used this code to run the storagenode:

sudo docker run -d --restart always --stop-timeout 300
-p 28967:28967
-e WALLET=“0x0000….”
-e EMAIL=""
-e ADDRESS=“myNoIPstuff:28967”
–log-opt max-size=50m
–log-opt max-file=10
–mount type=bind,source=/home/pi/.local/share/storj/identity/storagenode,destination=/app/identity
–mount type=bind,source=/mnt/storj/storagenode,destination=/app/config
–name storagenode storjlabs/storagenode:latest

  • Used the Cli dashboard command and was happy to see it online and watched it for three hours slowly raising in ingress and opened up myself a beer when egress was 2.3 MB! :+1:
  • Went to bed dreaming of shiploads of HDDs in the cellar.
  • Woke up this morning
  • Checked Cli dashboard
  • Storagenode Offline
  • Checked docker logs
  • Didn´t understand a single thing
  • Decided to start Corona Home Office Work later and read in this forum
  • Messed around with this log.output to file, the config.yaml on HDD
  • Stopped it and went to Home Office Work to late (never thought this is even possible?)
  • Today in the evening removed SD Card from RPi3
  • Reformatted the SD Card
  • Put new Lite Version without desktop onto it
  • Repeated nearly the whole process as above
    ** except: moving the backup of the identity to the hdd
    ** except: entering the NoIP Information directly into my router DynDNS thingy, so no DUC of NoIP
  • Result: Directly offline, no connection

I am stuck and totally irritated.

I thought, I repeat the process and then can check whether it is DDNS or Router or Local Area Network problem by forcing my router/my ISP to give me a new IP. And then see whether the node goes offline again. Problem area identification was the idea.

Because I think I messed something with the logs it is difficult for me to keep the overview.

Identity Check gives 2 and 3.

Run Code for docker:

docker run -d --restart always --stop-timeout 300
-p 28967:28967
-e WALLET=“my wallet thing”
-e EMAIL=“my mail”
-e ADDRESS=“myNoIPStuff:28967”
–log-opt max-size=50m
–log-opt max-file=10
–mount type=bind,source=/mnt/storj/storagenode/identity/storagenode,destination=/app/identity
–mount type=bind,source=/mnt/storj/,destination=/app/config
–name storagenode storjlabs/storagenode:latest

In Regards to Identity path…yes looks wierd, but it is like that, except I tried with these two:

  • /mnt/storj/storagenode/identity/storagenode
  • /mnt/storj/storagenode/identity/
    Both lead to offline, the 5 (cert) files are here: /mnt/storj/storagenode/identity/storagenode
    File number 6 is in: /mnt/storj/storagenode/identity

I still imagine it is a port issue and/or something with the Router, LAN - somewhere here.

The WAN IP in the Router is the same as in getyoursignal as in NoIP. Is WAN IP the correct them?
Router shows green for the Port forwards.
You get signal still says “closed”. But I ignored that yesterday also, so dunno?

Can you help me?

I bet I forgot to tell something else I did, it is really a lengthy process for a rookie.
I bet it is something easy.

I am currently rechecking the identity stuff myself here: My Node is OFFLINE for 2 hours

This is so recommended in many posts.


  • Filesizes of certs fit.
  • cert and keys files = 5
  • revocations.db is the file number 6 in the directory above “storagenode” in “identity”

Still…yougetsignal = closed …but why? Storagenode is running also…hmmm

Hello @Barn,
Welcome to the forum!

Please, check your DDNS domain:


It should show the same IP as your WAN IP and as your IP on yougetsignal.
Also, please, show the last 10 lines from the log:

docker logs --tail 10 storagenode

Did nslookup this second. Is correct. Same IP as WAN IP in Router and in yougetsignal.

Wuhu! It is Alexey! BÄM! Problem Solver! Nice to meet you!

Last 10 lines of log:

2020-07-29T19:42:14.144Z INFO Telemetry enabled
2020-07-29T19:42:14.201Z INFO db.migration Database Version {“version”: 42}
2020-07-29T19:42:15.435Z INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.
2020-07-29T19:42:26.188Z INFO preflight:localtime local system clock is in sync with trusted satellites’ system clock.
2020-07-29T19:42:26.189Z INFO trust Scheduling next refresh {“after”: “5h46m10.17784126s”}
2020-07-29T19:42:26.190Z INFO Node 1Kg75pooruDiazDwMwZpJ6dcLALv3zwMPrDmgCR7J4Di3aoeFL started
2020-07-29T19:42:26.190Z INFO Public server started on [::]:28967
2020-07-29T19:42:26.190Z INFO Private server started on
2020-07-29T19:42:26.191Z WARN piecestore:monitor Disk space is less than requested. Allocating space {“bytes”: 933310380288}
2020-07-29T19:42:26.191Z INFO bandwidth Performing bandwidth usage rollups


Show output of

df -h

Thanks alot for your assistance!

Filesystem Size Used Avail Use% Mounted on
/dev/root 7.1G 1.6G 5.2G 24% /
devtmpfs 459M 0 459M 0% /dev
tmpfs 464M 0 464M 0% /dev/shm
tmpfs 464M 6.3M 457M 2% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 464M 0 464M 0% /sys/fs/cgroup
/dev/mmcblk0p1 253M 51M 202M 21% /boot
/dev/sda 916G 2.8G 867G 1% /mnt/storj

seems one cert/key file is still missed
Could you show the result of the command:

ls -l /mnt/storj/storagenode/identity/storagenode

Here it is the output:

total 20
-rw-r–r-- 1 pi pi 518 Jul 29 18:37 ca.1595932115.cert
-rw-r–r-- 1 pi pi 1044 Jul 29 18:37 ca.cert
-rw-r–r-- 1 pi pi 1060 Jul 29 18:37 identity.1595932115.cert
-rw-r–r-- 1 pi pi 1586 Jul 29 18:37 identity.cert
-rw-r–r-- 1 pi pi 241 Jul 29 18:37 identity.key

Did I miss one in the backup? hmm…

You cannot assign space that you don’t have. If you have read the documentation it clearly states to assign only 90% of “available” free space and keep 10% for overhead.

A 1TB HDD does NOT have 1TB of usable space :slight_smile:

:slight_smile: Sounds reasonable. Thanks a lot.

I didn´t read or least recognized that, I admit.
Will change it.

docker stop and then rm and change run command variable and then start again, I think. Sounds doable.

1 Like

You are missing ca.key

You should lower your storage allocation to 900GB. It is overallocating now which will cause problems once the node fills up.

ca.key seems to be missing but shouldn’t be needed to run the node. Just make sure you still have it somewhere safe.

As for the port being closed, that’s likely your issue. When you ignored it the first time the node may not have been running at the time. The port only shows as open when the node is running. You checked your WAN IP, so that’s good. Make sure the LAN IP of your node hasn’t changed and double check the port forward setting in your router too.

Edit: that’s what I get for posting long messages on my phone, others beat me to some of this. Sorry for repeating.

1 Like

Its a well known fact your posts are always welcomed and :heart: by all :slight_smile: irrespective of their length.

1 Like

Before I reply to @BrightSilence… though being new here, I share that feeling based on my readings in the past days. Welcomed and respected because skilled and awesomely helpful.


Disk Space Check.

  • Will do that. Thanks too.


  • I have it somewhere. Safe.

Port closed issue

  • LAN IP is set static for Pi and shows up accordingly in the router. I changed it myself in the second setup round. Also double checked it. ifconfig, ping, router overview, all seems good. I will check port forwarding once more.

Thanks a lot.

–mount type=bind,source=/mnt/storj,destination=/app/config

Not “-” only “–” (two -)
Not “/mnt/storj/” only “/mnt/storj”

Not Windows Notepad, only Notepad++

Windows Editor Encoding Shizzle Whizzle Trap?
Okay thanks. Will use Notepad ++.

Can you lead me to the mnt/storj difference? I cannot see it?
Curly quotes wrong?

Now it is online. :+1:


  • I checked the portforwarding rules for IP4 and IP6 I created on port 28967
  • But then I remembered “Hey Barn, you didn´t care about giving the static IP6 adress and gave none/left it dead with the # in front”
  • so I deleted the IP6 port forward rule
  • and instantly in the yougetsignal page right hand side
  • boom - green - open
  • Cli dashboard ONLINE

Is it accicdentially or does it make sense?
Everything else was good and correct in the settings!?

1 Like

“/” at the end

but since it works / is online, it obviously doesn’t matter …

I’ve seen no issues with anything you posted. Unfortunately the forum messes with things like the docker run command. You can circumvent that by posting code between two lines with only three backticks on them like this.

code here

IPv6 doesn’t really have port forwards, you just open a port through the firewall. So I’m not entirely sure what you’re referring to. You don’t really need IPv6 anyway. Currently there is only one satellite that even understands IPv6 and on dual stack setups even that one will default to IPv4. It’s good to see you’re up and running again. Hope it sticks this time!