My Node is OFFLINE for 2 hours

Hello
I just set up my node today. I benn waited 2 hours but it’s still said OFFLINE.
I tried to restart it but it is the same OFFLINE.
Do I need to wait more than 2 hours or is it a problem?
Thanks!

1 Like

It should connect in seconds. There are a few things you should check.

Start with checking the port. On https://www.yougetsignal.com/tools/open-ports/?port=28967 you can fill in the domain or IP you are using in the run command. Then check the port.

If it’s closed, it could still be several things.

  • Make sure the WAN IP you see in your router settings matches the IP shown on the above page.
  • Make sure your port forward is set up correctly. That means no filter on incoming IPs, forwarding to the IP of your node on the local lan. Set to TCP and port 28967.
  • If you’re running a firewall, make sure you allow incoming traffic on port 28967.
  • Make sure you’re not blocking any outgoing traffic from your node’s IP to any port. Make an explicit rule to allow that if needed.

You can keep using the page linked above to verify. It will only show the port as open if your node is running.

If the port does show up as open, it’s likely because your identity isn’t signed (correctly).

Check this:

docker exec -it storagenode ls -l /app/identity

You should have 6 files in there. ca.cert should be 10xx bytes and identity.cert should be 15xx bytes. If you are missing files or these two files are smaller, your identity isn’t signed correctly. Please follow the instructions on how to sign again. If your token was already used, try to find the folder with the 6 files of the right size. Your token is one use only, so don’t lose your signed identity files.

2 Likes

The only other piece I noted that I wasn’t sure of was that the dashboard is showing offline still. At what point in the vetting should I show as online?

Storage Node Dashboard ( Node Version: v0.15.3 )

======================

ID mylongnodeidofreallylongnumbersandletters
Last Contact OFFLINE
Uptime 20m2s

               Available     Used     Egress     Ingress
 Bandwidth       40.0 TB      0 B        0 B         0 B (since Jul 1)
      Disk       23.0 TB      0 B

Bootstrap bootstrap.storj.io:8888
Internal 127.0.0.1:7778
External my.DynDns.ca:28967

Neighborhood Size 138

Please, check all points from there: My Node is OFFLINE for 2 hours

I can only add, that your DDNS address doesn’t looks right.
Please, check it: nslookup my.DynDns.ca 8.8.8.8

1 Like

Ahh I used the link to check the port status and noticed another problem with the forwarding.

Now receiving the first bits of data…

Storage Node Dashboard ( Node Version: v0.15.3 )

======================

ID mystilsuperlongidaddressoflotsoflettersandnumbers
Last Contact 0s ago
Uptime 10m37s

               Available         Used     Egress      Ingress
 Bandwidth       40.0 TB     197.5 MB        0 B     197.5 MB (since Jul 1)
      Disk       23.0 TB      77.5 MB

Bootstrap bootstrap.storj.io:8888
Internal 127.0.0.1:7778
External my.dyndns.ca:28967

Neighborhood Size 138

Checking the logs I see this in the logs. Not sure if it is something to be concerned about:

2019-07-20T14:52:37.250Z ERROR piecestore protocol: rpc error: code = Canceled desc = context canceled
storj.io/storj/storagenode/piecestore.(*Endpoint).Upload:238
storj.io/storj/pkg/pb._Piecestore_Upload_Handler:701
storj.io/storj/pkg/server.logOnErrorStreamInterceptor:23
google.golang.org/grpc.(*Server).processStreamingRPC:1209
google.golang.org/grpc.(*Server).handleStream:1282
google.golang.org/grpc.(*Server).serveStreams.func1.1:717

If that normal type of error indicating a node cancelled its transfer with me? or something indicating a problem?

About known errors you can read here: Error Codes: What they mean and Severity Level [READ FIRST]

1 Like

Perfect! Thank-you for the help! My node seems to be online and running. I’ll wait the required time to get my reputation up and then do a quick maintenance to move this node into the rack and start on my second node.

2 Likes

Im calling it crashing but what happened was that LAST CONTACT showed +72h, it worked fine but ofc that worried me as repairs are triggered after 1-2hours of no contact, I restarted the Docker containers and now its showing OFFLINE

From the duration that the node didnt contact the satellites I assume I may have lost all my reputation/vetting ?

What is your OS?
If Windows or MacOS try to restart the Docker from the Docker desktop application.

6 posts were merged into an existing topic: Last contact 19 hours ago or OFFLINE on Windows/MacOS

None of those Im running it on Ubuntu 18.04, using command line

Right now I have checked my DNS, Port, Checked the Identities ( even though they havent changed this month ) and my pfSense, I think I just found it, my public IP changed (not sure yet )

Please, compare your address from the ADDRESS option of your docker run command with IP there: https://www.yougetsignal.com/tools/open-ports/

Had just realized it, but that was the issue Alexey, sorry for writing a post for such a nuisance.
I know we cant check reputation, but what does usually happen in 72h no contact

With OFFLINE status your reputation will be hitting, but the pausing for the low uptime currently is disabled.

Hi !

My post : Upgraded my node to v0.15.3 - Not sure if i have a issue

were merged :
6 posts were merged into an existing topic: Last contact 19 hours ago or OFFLINE on Windows/MacOS

I’m using Raspberry Pi and I have already rebooted few times, it didn’t resolve the issue,

And in my logs i have a huge amount of INFO running on version v0.15.3, running for 2/3 days like that. Should i wait more for the vetting process or i have a problem with my node ?

Thanks,


Storage Node Dashboard ( Node Version: v0.15.3 )

======================

ID X
Last Contact OFFLINE
Uptime 28h21m7s


2019-07-24T12:06:17.700Z INFO running on version v0.15.3

2019-07-24T12:06:17.779Z INFO db.migration Latest Version {“version”: 13}

2019-07-24T12:06:17.784Z INFO vouchers Checking vouchers

2019-07-24T12:06:17.787Z INFO Node X started

2019-07-24T12:06:17.788Z INFO Public server started on [::]:28967

2019-07-24T12:06:17.788Z INFO Private server started on 127.0.0.1:7778

2019-07-24T12:06:17.792Z INFO vouchers Requesting voucher {“satellite”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”}

2019-07-24T12:06:17.797Z INFO vouchers Requesting voucher {“satellite”: “12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S”}

2019-07-24T12:06:17.794Z INFO vouchers Requesting voucher {“satellite”: “12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs”}

2019-07-24T12:06:17.830Z INFO running on version v0.15.3

2019-07-24T12:06:27.217Z INFO vouchers Voucher request denied. Vetting process not yet complete

2019-07-24T12:06:39.123Z INFO piecestore:monitor Remaining Bandwidth {“bytes”: 19934849497856}

2019-07-24T12:06:43.489Z INFO vouchers Voucher request denied. Vetting process not yet complete

2019-07-24T12:06:51.927Z INFO vouchers Voucher request denied. Vetting process not yet complete

2019-07-24T12:21:27.072Z INFO running on version v0.15.3

2019-07-24T12:36:27.094Z INFO running on version v0.15.3

2019-07-24T12:51:27.133Z INFO running on version v0.15.3

2019-07-24T13:06:27.142Z INFO running on version v0.15.3

2019-07-24T13:21:27.104Z INFO running on version v0.15.3

2019-07-24T13:36:27.103Z INFO running on version v0.15.3

Hello @XNcow,
Welcome to the forum!

If your OS is Windows or MacOS try to restart the Docker from the Docker desktop application

Moved to here. Sorry about that :slight_smile:

Please, compare your WAN IP from the main page of your router with IP there: https://www.yougetsignal.com/tools/open-ports/
They should match, otherwise your port forwarding will not work.
Please, compare the IP from the

nslookup your.ddns.address 8.8.8.8

with both IPs above - it should be the same.
Please, check your port forwarding rule, it should have the same local IP as the IP of your RPI3.

Resolved.
Was a router issue :slight_smile:

Thanks for support !

1 Like

4 posts were merged into an existing topic: Last contact 19 hours ago or OFFLINE on Windows/MacOS