New node appears offline

I started a new node and it appears offline. I checked that my port 28967 is open to the outside world.
What else can be the issue?

This question has been asked many times, so I’ll link you to another post where I already responded in detail.

One additional node. Since this topic Kademlia has been removed from the node software which causes Last Contact to not update as often by far. It can go up to a few minutes now. But it should not show as OFFLINE.

1 Like

i don’t think this is the issue.
I looked at the post you mentioned before I sent my query. The port is open and is allowing the storj traffic to come in. There must be another reason.
This is the command I use to run Storj:
sudo docker run -d --restart unless-stopped -p 12345:28967 \ │
-e WALLET=“0x99969Df2dA9BF780Cfd62D7cC22f77E5BdB332df” \ │
-e EMAIL="" \ │
-e ADDRESS=“” \ │
-e BANDWIDTH=“61.5TB” \ │
-e STORAGE=“7TB” \ │
–mount type=bind,source="/usr/local/share/storj/identity",destinatio│
n=/app/identity \ │
–mount type=bind,source="/media/Seagate_8T_2/Node",destination=/app/│
config \ │
–name storagenode storjlabs/storagenode:arm

What do you think?

The other thing mentioned in that topic and others. Your identity.

1 Like

I am getting the following results when running the command you suggested:
total 48 │
-rw-r–r-- 1 1000 1000 546 Sep 24 18:24 ca.1569345250.cert │
-rw-r–r-- 1 1000 1000 1076 Sep 24 18:24 ca.cert │
-rw------- 1 1000 1000 241 Sep 24 18:24 ca.key │
-rw-r–r-- 1 1000 1000 1084 Sep 24 18:24 identity.1569345250.cer│
t │
-rw-r–r-- 1 1000 1000 1614 Sep 24 18:24 identity.cert │
-rw------- 1 1000 1000 241 Sep 24 18:24 identity.key │
-rw------- 1 1000 1000 32768 Sep 24 18:24 revocations.db

I think it looks OK. What do you think?

Port configuration?

What does your log say?

The internal IP is:
The open port is:
Destination Ports 12345

TCP Any -> 12345

UDP Any -> 12345

I think this is good.

Sorry, Alexey.
What would be the command to view the logs?
Thank you

I found the command.
This is what the logs say.
c error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsT│········
.func1:68\n\*Group).Go.func1:57\n— node stats ser│········
vice error: rpc error: code = PermissionDenied desc = node not found: 1c3wcd3hAe│········
c error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsT│·······uBQmMtTykVGKvvTBKjnjXwuLaZ\n\*Service).Ge│·······
/internal/sync2.(*Cycle).Run:147\n\*Cycle).Start│·······.func1:68\n\*Group).Go.func1:57\n— node stats ser│·······
c error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsT│······uBQmMtTykVGKvvTBKjnjXwuLaZ\n\*Service).Ge│······tReputationStats:79\n\*Cache).CacheReputa│······
c error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsT│····c error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsT│··c error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsT│c error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsc error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsT│·c error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1Ptc error: code = PermissionDenied desc = node not found: 1c3wcd3hAeUuBmECG1PtNgsT│uBQmMtTykVGKvvTBKjnjXwuLaZ\n\*Service).Ge│tReputationStats:79\n\*Cache).CacheReputa│tionStats.func1:108\n\*Cache).satelliteLo│op:170\n\*Cache).CacheReputationStats:107│\n\*Cache).Run.func1:79\n\│/internal/sync2.(*Cycle).Run:147\n\*Cycle).Start│.func1:68\n\*Group).Go.func1:57\n— node stats ser│vice error: rpc error: code = PermissionDenied desc = node not found: 1c3wcd3hAe│UuBmECG1PtNgsTuBQmMtTykVGKvvTBKjnjXwuLaZ\n\│.(*Service).GetReputationStats:79\n\*Cach│e).CacheReputationStats.func1:108\n\*Cach│e).satelliteLoop:170\n\*Cache).CacheReput│ationStats:107\n\*Cache).Run.func1:79\n\t│*Cycle).Run:147\n\│(*Cycle).Start.func1:68\n\*Group).Go.func1:57"} │2019-09-25T14:11:02.104Z INFO version running on version v0.21.1 │2019-09-25T14:26:02.169Z INFO version running on version v0.21.1 │2019-09-25T14:30:08.187Z ERROR contact:chore pingSatellites failed {│"error": “rpc error: code = Unknown desc = contact: couldn’t connect to client a│t addr: due to internal error.”}

I believe those PermissionDenied errors are because your identity is not correct. Did you move it from another node or something?

Personally, I don’t change the Internal/External port configuration. I use the router to use a different external port, and have it translate to the standard internal port. That way everything is controlled in one spot. So, I’m not sure if your port configuration will work, as I haven’t tried it that way. It might, I just don’t know.

I did not move the identity from another node.
This is a new node with a new identity key.
So, I guess we don’t know why it is not working.
Is there a way to correct the identity? I used the storj documents to create and authenticate it. Is there a specific folder in the hierarchy that the identity needs to be in? Maybe the folder is in the wrong place…

I really have no clue what you mean here… I see 2 different IP’s (typo?) and you have different ports mentioned. UDP is not used by your node at all.
Can you please instead post screenshots of your settings and your run command. Because port 28967 being open is of no use if you’re actually using port 12345… I’m seriously confused about what your saying here.

1 Like

It was a typo. Sorry abut that.
I attached the screenshots of the router settings and the run command.
Thanks for your patience.

The machine that does not get Storj traffic is the Rockpro64.
I am also showing the configuration for a node that does work. It is the Rock64 machine.
The start command screenshot is also attached.
thanks for taking a look.

Ok it seems like you’re checking port 28967, which is indeed open, but that’s used by the other node. Port 12345 used by this node is not open, so some firewall must be blocking it. Either on your router/modem in ISP settings or on the node itself. If you have firewalls anywhere allow incoming traffic on 12345. You only need TCP so you can remove the UDP forward if you want, though it won’t hurt your node either. But why have ports open you dont need.

Also, I noticed your using /media mount point in your docker command. The hard drive should be statically mounted using /etc/fstab.


The machine is online now. Thanks for your help. The issue was with the Port forwarding as Alexey said.
Thanks again.

While @Alexey is undoubtedly a problem solving legend, I don’t see him on this thread. Regardless, I’m glad you got it fixed.

Don’t ignore what @Dylan mentioned though. /media mounts tend to change names from time to time which would lead to your node failing or worse storing data inside the container. You should really be using fstab.

Sorry, my mistake. Thought you were him… :grinning:
You were a great help, and so is Dylan.
I checked the mount is static in /etc/fstab


1 Like