Nodestats:cache Get disk space usage query failed

You can restart by simply using docker restart -t 300 storagenode. But it shouldn’t be necessary.

Please make sure the WAN IP of your router is the same as the IP shown on yougetsignal. You might be behind a CGN. Unfortunately many ISPs are moving to such a model.

I have tried this docker restart command, do not work:

router shows the same WAN ip as yougetsignal, then CGN is not the case?

Looks like a docker issue. Try to restart a docker daemon

1 Like

Correct, CGN would put you behind a NAT causing your WAN IP to be different from your public IP.

Made restart for docker daemon and computer and still offline

This is the only way i can restart docker node

So I guess I have no other options to debug my issue?

I will do a clean install to my “Ubuntu Server” and the whole storj process?

Something wrong with your iptables.
You should add an incoming rule for 28967 to your PC interface, not to the docker interface.
You should add an outgoing rule for any port and any destination from your PC interface, not the Docker.

I have not changed the iptables by myself… the rule you see is added from docker installation automatically I think…
The guide of “Setting up storj node” is not telling anything about adding rules to the iptables.
So what should I add there exactly?

I enabled ufw and found some of your instructions from some other post
“TCP 28967 is sudo ufw allow 28967/tcp
To allow the outgoing traffic: sudo ufw allow from , where is your local IP”

My ufw is now this
To Action From

28967/tcp ALLOW Anywhere
Anywhere ALLOW
28967/tcp (v6) ALLOW Anywhere (v6)

restarted the node. Still the same error

and yes I enabled ufc, it filled the iptables as well

you don’t need to enable a ufw, if you have iptables configured.

Ok, please write down your WAN IP somewhere, then write down your public IP from there:
Then check your DDNS: nslookup your.ddns
Please, compare all three IPs, they must be the same.
Make sure that you have specified the ADDRESS option with the port, for example -e ADDRESS=your.ddns:28967
Please, remove the rule lan to wan with 28967 from your router and disable ufw.

Thanks for the suggestions but still the same error:
Removed all other rules from the router firewall, only wan to lan 28967 tcpudp remained.
Node execution command has -e address WITH port

sudo docker run -d --restart unless-stopped -p 28967:28967 -e WALLET=“0xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx” -e EMAIL="" -e ADDRESS=“” -e BANDWIDTH=“xxxTB” -e STORAGE=“xxTB” --mount type=bind,source="/home/xxxxxxxxxxxxxx/storj/signedStorageNodeIdentity",destination=/app/identity --mount type=bind,source="/mnt/storj0/",destination=/app/config --name storj0 storjlabs/storagenode:beta^C

disabled ufw and rebooted the machine.
All three addresses are same

Please, search for a firewall on your router, and make an incoming rule for TCP 28967 port to your PC with docker or disable it.

It is not router issue. I allowed unrestricted Internet access to the network device from the ROUTER (Exposed Host) where I have storj in. Restarted the router, machine, docker, node => still the same error.

ok then try the different port with nc, something like that:

nc -l 28968

and try from the internet

nc your.ddns 28968

Type something in the last terminal and make sure that you see the same text on the first one.

nc is a good thing for debugging, thanks for that.

if I do “nc -l 28968” in my machine and write text then I can get to see the text from other computer when the other computer is in the same LAN.

But when I try from WAN then I get no access although I have forwarded the ports in the router.

Does it mean that the my router is not able to forward ports correctly and I have to contact my service provider?

It does mean that your router blocks incoming traffic for some reason, or even your ISP (you can take a look on: USA Comcast xFi Advanced blocking warning)
Just make sure that you have trying to connect to the nc from the outside of your LAN: some routers are unable to make a hairpin connection to the external address from the internal network

Thank you Alexey!

Problem solved, I learned a lot whiled debugging this.

Turned out that my Internet Service Provider had all ports closed by default (for security reasons)! Please add this suggestion to the instructions under “Port forwarding” of “Setting up new storage node”. In my case I just had to log in to the online customer service of my Service Provider and clicked “Open ports”. (But you still have to forward the ports from your router as well).


I got this error and my node is offline

nodestats:cache Get disk space usage query failed

Please, fix your offline status: