Node wont go ONLINE - New Setup

Hi, Im new to setting up StorJ but am experienced with servers and cannot figure out whats wrong.

I have StorJ running on a Debian 9 VM (Now Ubuntu 19) and ports forwarded but, when running my Last Contact is OFFLINE and I get this in my logs:

Any ideas on whats wrong?
Using a port checker also states that the port is closed. Though this would have to be a application error as I have multiple other ports open and have ensured that the ports are open on the Debian machine.

EDIT: Here is the link to my node if it helps…

Hey @Inrixia
Welcome to the forums.

This is a common question that has been asked several times before. It’s always good to use the search function to look for your issue.

You can find a lot of suggestions here, but let me know if you don’t find a solution among them.

Ive already looked around and found no posts that have helped as most are just people misconfiguring domain or port forwarding. Is there anything specific I should do other than opening the ports in my router and in the VM?

Im gonna try installing a fresh Ubuntu 19 VM and see if it works better there. I have a copy of my identity and keys saved.

The offline status could be related only to the two things:

  1. network poblems:
  1. Problems with identity
docker exec -it storagenode grep -c BEGIN /app/identity/ca.cert
docker exec -it storagenode grep -c BEGIN /app/identity/identity.cert

The result should be
Otherwise your identity is not signed and you need to have an authorization token to sign it:

Identity is correct. Just did a clean install on a Ubuntu 19 VM and am still not going online…

I’ve done “sudo ufw allow 28967” on the ubuntu machine to make sure the port is not blocked and I know its forwarded but its still not connecting. What can I do? Getting the same errors in my log as the previous machine.

Here is a picture of my dash if it helps:

Hostname blacked out.

EDIT: Also just tried with a different port and same error.
EDIT: Also tried without using hostname and just my WAN IP, same error.
EDIT: Disabled ufw on the machine and still no change.

I’m completely lost at this point as to whats causing it. I have followed the install instructions exactly, everything is forwarded and my domain is all working (I can confirm this as I have multiple other services forwarded and working on my network using said domain and port forwarding).

Yet I still receive errors in logs and my node wont connect, please if you have any idea of something I can do to fix this let me know.

external address is nothing we could ping. That is the reason you are offline. 2 users have linked you guides that would have covered that mistake. So please read what they have linked and lets us know at which point you can’t follow.

What do you mean at which point can I not follow. I have already gone over all the guides, and I blacked out my external domain as I do not wish to share it here, so I have no idea why you would say you cannot ping my external address when you dont have it.

There is not a point where I get stuck on the guides, I have setup everything correctly following the docs exactly three times now with clean installs and countless times without clean installs, including port forwarding with different ports.

If you have any idea as to what I can do then let me know but just saying to “look at the guides people have linked” After I have already looked through every issue I can find that is relevant on this form and come up blank is not helpful…

EDIT: Also to note that if there is a connectivity error it must be within docker as I know for certain that the domain etc that I am using is valid since I have multiple other live services running atm off it, all of which are port forwarded and running on VM’s identical to the one that StorJ is currently running.

Can you send me a PM with your external address?

All I know at the moment is that your nodeID can’t be found in the kademlia network. It doesn’t need to be the port forwarding.

DM’d, sorry if my previous message came off as rude btw.

Hopefully this can get sorted :slight_smile:

Thats fine. I did requests it :smiley:

Please, copy your WAN IP from the main page of your router here or just in the notepad.
Then go to the and take the IP from there.
If those two IPs are different - the port forwarding will not work. This is most frequently problem these days. Because you need to have a public IPv4, which ISP don’t want to give you for free.
Also, if you have a two routers between ISP and your PC, you need to have port forward on both routers: from the Internet to the second router and on the second to your PC with docker

I am such a idiot… All the diagnostics and I never realized that the port 28967 is within the range of a big number of addresses I had open in another rule, UniFi sadly does not notify you of port conflicts. I’m moving that service to a different port range that does not overlap and its working now.

Honestly I feel soo stupid, thanks so much for the help. I am amazed that it took me this long to realize ;-;