Problems with node

Good morning,

I have some problems with a node with ± 10months.

Suddenly, the node has started to go offline overnight without making any changes to either the node or the network.

I have two nodes in place, one as I say about 10 months and the other 4, so far working perfectly until today.

This is the log that throws me but does not give much information.

2021-04-22T17:08:24.157+0200 ERROR contact:service ping satellite failed {"Satellite ID": "121RTSDpyNZVcEU84Ticf2L1ntiuUimbWgfATz21tuvgk3vzoA6", "attempts": 5, "error": "ping satellite error: failed to dial storage node (ID: MY_NODE_ID) at address MY_DDNS:28967: rpc: dial tcp i/o timeout", "errorVerbose": "ping satellite error: failed to dial storage node (ID: MY_NODE_ID) at address MY_DDNS:28967: rpc: dial tcp MY_PUBLIC_IP:28967: i/o timeout\n\*Service).pingSatelliteOnce:141\n\*Service).pingSatellite:95\n\*Chore).updateCycles.func1:87\n\*Cycle).Run:92\n\*Cycle).Start.func1:71\n\*Group).Go.func1:57"}

Say that the port and non-IP settings are correct and have not been modified.

I have reinstalled in case it was a version problem but I’m still the same.

Actually i have v1.27.6.

Any ideas?


I can see this logs too

2021-04-22T17:11:49.987+0200	INFO	**Public server started on [::]:28967**
2021-04-22T17:11:49.987+0200	INFO	Private server started on
2021-04-22T17:11:49.989+0200	ERROR	**collector	unable to delete piece**	{"Satellite ID": "12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs", "Piece ID": "B3HHCA6BXDBG3IHNCGYMJREGVG2ROHHORQ4RKNQOOMDPBAPYUWQQ", "error": "pieces error: filestore error: **file does not exist",** "errorVerbose": "pieces error: filestore error: file does not exist\n\*blobStore).Stat:99\n\*BlobsUsageCache).pieceSizes:239\n\*BlobsUsageCache).Delete:220\n\*Store).Delete:299\n\*Service).Collect:97\n\*Service).Run.func1:57\n\*Cycle).Run:92\n\*Service).Run:53\n\*Group).Run.func2.1:81\n\truntime/pprof.Do:40\n\*Group).Run.func2:80\n\*Group).Go.func1:57"}

Hi @Kyshino,
Please check for open port using both dns name and the public IP - Open Port Check Tool - Test Port Forwarding on Your Router

Is your node on Windows or on Linux?

You should check your hard drive for errors. That’s one possible explanation for this.

2 posts were split to a new topic: Su nodo ha sido descalificado

Is windows, the harddrives are ok.

Make sure your ddns is updated.

A post was merged into an existing topic: Su nodo ha sido descalificado

Is your data on a Storage Spaces Pool? I had this issue with my Windows using Storage Spaces where a Windows Update corrupted part of the data in my pool. Checkdisk kept on finding errors, “fixing” them and losing files every time I ran it. In my case the solution was to copy the files somewhere else and my node started to work again.

I have no RAIDs, all is in the same phisic HDD.

Any help @Alexey ?

Clearly states that your node is not available from outside.
Please use this checklist to fix the issue:

I personally think that your ISP either changed your external IP and your DDNS updater doesn’t work or your ISP placed you behind their NAT (CGNAT).

Also, maybe you forgot to confirm/extend your DDNS subscription. For example, requires to confirm your DDNS every month on free account.