Identity_windows_amd64.exe completes quickly, generates 4 files

Hello everyone, I’m new to Storj but this appears to be a great community. I’m looking forward to being part of it.

So I decided to give Storj a shot on Win10 and found the setup to be fairly straightforward but ran into a problem I wasn’t aware of until I attempted to fire up my node. It wouldn’t come online so I started troubleshooting. I discovered that when I created my identity, it did not create all 6 necessary files as documented in the install guide and on this thread My Node is OFFLINE for 2 hours. When I initially ran identity_windows_amd64.exe, it completed in under 5 seconds on an older Celeron so I was a bit shocked but figured I got lucky. So, per the install guide I re-ran “identity_windows_amd64.exe create storagenode” again and again. Each time it completes in under 30 seconds, reports no errors but only generates 4 files. (ca.cert, ca.key, identity.cert, identity.key). I’ve now tried running it on 3 different Win 10 machines with the same result. Hoping someone can shed some light on what the issue could be. Also wondering if I’m screwed now since I have already used my auth token against an invalid identity? Appreciate any input. Thanks!

Hello @the_kegs,
Welcome to the forum!

You just missed the part to sign your identity with an one-time authorization token.
If you do not have one, you should subscribe to the waitlist.

1 Like

Alexey,

Thanks for the welcome and quick reply. OK gotcha on the 6 files only showing up after you sign. Is it still normal for it to complete so quickly? The guide says hours to day depending on your machine. I’m running it on an older machine and every time it completes in under 30 seconds?

Let me backup a little and do a better job of explaining. I do have an authorization token and I did use it to sign. My first time through the identity process I ran “identity_windows_amd64.exe create storagenode” then initiated the signing process. After the signing process I backed up the identity folder as directed, I just didn’t pay attention that the directory only had 5 files in it vs the 6 outlined in the install guide. I’m thinking this is the problem why my node isn’t going online. I’ve verified the port is being forwarded by starting up a different service utilizing 28967 but when running the node on 28967 it’s showing as closed when I hit it externally. Thanks again

It could be possible, it’s depends on CPU type and some specific instructions, which it can handle.

You can easily check the status of signing for your identity:

Those commands should return 2 and 3 respectively.
If not - your identity is not signed, in such case you should subscribe to the waitlist again with a different email address to receive a new authorization token

1 Like

I’ve heard several people say they got it very quickly, so I figured I’d take a look. I think there have been some optimizations. Back when I generated my identity it took a whole lot longer.

Thanks for the help, it got me pointed in the right direction. I restored my original identity folder, ran the commands and they returned 2 and 3 as expected. I was initially setting this up on wifi but discovered the adapter I was using was experiencing extreme latency and intermittent connection. I switched over to ethernet and now my node shows that it’s online. I looked at my logs and everything is showing normal except for the following error. Not actually sure the node is up as the dashboard is showing no activity as of yet. Could find much about it on the forum or elsewhere online. ERROR server gRPC unary error response {“error”: “rpc error: code = PermissionDenied desc = untrusted peer 1QzDKGHDeyuRxbvZhcwHU3syxTYtU1jHy5duAKuPxja3XC8ttk”}

Thanks again!

1 Like

You guys are great, thanks for the help. I have data flowing in and out of my node so it appears everything is working as expected.