Assistance Requested in Node Setup

I’m a first timer so please go easy on me. I’ve spent a few hours trying to figure this out…

I’ve successfully generated an Identity, verified I have all 6 files, but I can’t get the services/local host (Window) to connect to the satellites.

I’m running a Linksys router and I’ve configured the DDNS in the router with NoIP and have enabled PORT forwarding on 28967.

I’m not really sure what I’m missing. Any suggestions?

Error Log:
021-03-26T13:03:22.145-0500 INFO db.migration Database Version {“version”: 51}

2021-03-26T13:03:22.538-0500 INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.

2021-03-26T13:03:23.092-0500 INFO preflight:localtime local system clock is in sync with trusted satellites’ system clock.

2021-03-26T13:03:23.092-0500 INFO trust Scheduling next refresh {“after”: “7h44m0.67167985s”}

2021-03-26T13:03:23.092-0500 INFO Node 1QAjMSSi9o5G3of58PW1bfqkAdo1TgDMK5F78MJQEFWXe653Z5 started

2021-03-26T13:03:23.092-0500 INFO Public server started on [::]:28967

2021-03-26T13:03:23.092-0500 INFO Private server started on 127.0.0.1:7778

2021-03-26T13:03:23.092-0500 INFO bandwidth Performing bandwidth usage rollups

2021-03-26T13:03:43.363-0500 ERROR contact:service ping satellite failed {“Satellite ID”: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE”, “attempts”: 1

Check your No ip ddns

I have the DUC app running and it has 3 check marks so I think I’m good there. Are you aware of any guides for debugging?

Hello @shadedred ,
Welcome to the forum!

Please, check your WAN IP on your router and compare it with IP there: Open Port Check Tool - Test Port Forwarding on Your Router, they should match, otherwise your port forwarding will not work.