Audit, upload and download errors

Hello All,

I run my v3 node on Raspberry Pi. I ran some of the scripts available on the forum to find out how my node is doing. From the outputs of those scripts, I see some errors/failures in audit, upload and download. Do you know where I can look to understand these errors and fix those? My concern is that I am missing on maximizing my node capacity.

-e ========== AUDIT =============
-e Successful: 178
-e Recoverable failed: 0
-e Unrecoverable failed: 34
-e Success Rate Min: 0.000%
-e Success Rate Max: 0.000%
-e ========== DOWNLOAD ==========
-e Successful: 45
-e Failed: 1013
-e Success Rate: 0.000%
-e ========== UPLOAD ============
-e Successful: 129
-e Rejected: 0
-e Failed: 1539
-e Acceptance Rate: 0.000%
-e Success Rate: 0.000%
-e ========== REPAIR DOWNLOAD ===
-e Successful: 0
-e Failed: 1
-e Success Rate: nan%
-e ========== REPAIR UPLOAD =====
-e Successful: 2
-e Failed: 0
-e Success Rate: 0.000%


Sat ID: 118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW
Unrecoverable Failed Audits: 0
Recoverable Failed Audits: 27
Successful Audits: 2
Sat ID: 121RTSDpyNZVcEU84Ticf2L1ntiuUimbWgfATz21tuvgk3vzoA6
Unrecoverable Failed Audits: 0
Recoverable Failed Audits: 0
Successful Audits: 165
Sat ID: 12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs
Unrecoverable Failed Audits: 0
Recoverable Failed Audits: 8
Successful Audits: 11

The second script you used may be outdated. The wording of the missing file errors in the logs have changed, which I adjusted in the first script you used. The second script is probably using the old wording and wrongfully listing the errors as recoverable failed errors.

Your results suggest you have lost data and therefore are now failing audits. Make sure you have not lost any of the stored data and the data is still accessible to the node.

Please, make sure that your HDD is statically mounted via /etc/fstab
Please, update your docker run command: https://documentation.storj.io/setup/cli/storage-node#running-the-storage-node

Thanks for the replies @alexey and @BrightSilence. Recently, my node was hanging due to watchtower spawning 100s of instances. By the time @alexey gave a me a solution to kill, I re-imaged my Pi. I am mounting the drive using fstab configuration. I believe after re-imaging, when I connected back the hard disk, it got corrupted. At this point, I still see downloads and uploads, but I am not sure what the rank of my node and how much Storj is willing to push/pull data from my node. I have 1Gbps symmetrical link and 8TB drive. My concern is that I am not utilized to the fullest. I will continue to monitor my node and keep you posted on this.

You can check your score via storagenode API:


Or on the Web dashboard: https://documentation.storj.io/setup/cli/dashboard

I looked at the web dashboard and see that some satellites dropped disk usage and bandwidth drastically on October 6th. I feel that that was the time, my Pi got into docker spawning issue. I will keep it online as much I can to build back the reputation. If there is anything I can do to my node to improve or fix errors, please do let me know.

another view

@Alexey, you may not like to check individual nodes for issues, but if you could check mine from your side, I will truly appreciate.

I have a limited access to the information. You can see the same, as me from the storagenode API:

for sat in `docker exec -i storagenode wget -qO - localhost:14002/api/dashboard | jq .data.satellites[].id -r`; do docker exec -i storagenode wget -qO - localhost:14002/api/satellite/$sat | jq .data.id,.data.audit; done

From your screenshot I could say, that it’s online. The reputation (uptime checks and audits checks) you can see for each satellite individually on the web dashboard or from the API

1 Like