Average disk space used this month graph

this graph has lost its mind…
i’m not the only one seeing this…
not only is it negative for yesterday, but it also says 1.1TB avg used on a 7.2TB node which seems totally wrong unless if its still calculated in like TBm or something like that…

but certainly seems like something weird is going on with the satellite accounting.

1 Like

Already mentioned here:

Fix should be coming soon


I don’t think it’s exactly same issue as you pasted, anyway I have it too from today:

exactly the same here, v1.71.2

I see it on 2/3 of my nodes, my oldest, and my newest node. I had some downtime recently due to an ice storm. No power all night, and i thought that was it. But, appears i was incorrect. The middle one has plenty of freespace, so maybe it only impacts nodes nearly full? I also noticed briefly that one node was over-allocated by a few GB, but it resolved after a little while.

Same here, I only see the issue on 2 of my 3 nodes. But unlike you my one with space is one of the problem children, and one of my two full nodes shows the negative dip. Curious as to why they would be split like this but I didn’t learn anything as to how this might be in the github issue.

Glad this has been brought up in the forum, when I spotted this on my nodes I was rather concerned. Should this topic be pinned until fixed code is fully pushed? I do see the github issue was closed a few hours ago but I don’t know how long until all the necessary targets are updated. It’s not clear to me if this is a satellite or node side issue.

I also have the same graphs, this morning the curves are back, but the problem remains, I have 3.7 Tb and the graph is at 600 Gb. I already checked the db

The dip is fixed on my node aswell.
That the graph shows a too low value should be fixed by a commit i posted earlier in this thread


Another dashboard error is the delay in updating payments. I received the January payment on L2 nine hours ago, including the 50% held amount, but the dashboard still hasn’t updated

dashboard always was updated with some days delay after payment was made.

1 Like

Ah, ok, but that too should be fixed.
Ty @Vadim

You may just restart the storage node if you are in rush.

my graph is still wrong in v1.75.2

or maybe someone can explain how disk average is 1.94 when used space is 3.4+?

My graph with 1.75.2 looks correct

Hello @razvonescu,
Welcome to the forum!

Please check your databases:

Hi and thanks for your help Alexey,
I think I found the issue. I have started my node with 2TB then I increased to 3.5TB at some point back.
It looks like even if 3.5TB is recognized as valid capacity in the CLI and I god ingress traffic up to 3.5TB, it is not recognized in config.yaml and my The Average disk space used got stuck with the initial value. The Average disk space used went above 2TB after I changed in config.yaml to 3TB


Parameters in the docker run command have a precedence above parameters in the config.yaml.
However, for Windows GUI nodes only config.yaml file is used.

hi Alexey,

I have checked my databases and all are OK but my problem still persists.
Any other ideas?

If databases are correct, please check also disk with data.
How much space is actually used?

For Windows you may open properties of the folder with node’s data, it should calculate a used space.
for Linux you may use command

du -s --si /mnt/storj/storagenode/storage

hi Alexey,

I tried running the command but it took more than 48 hours with no result.
However, I run my node on QNAP NAS and I can confirm the size of the storage folder is similar to the one I see on Dashboard on Total Disk Space section, which is 1 TB more than the Average Disk Space Used This Month.

I run a file system check, and did all kind of tests, my HDDs are fine, but I can see a “error getting current space used calculation” when I start the node.

Any other suggestions?

btw, I created my node using this command:

docker run -d --restart always --stop-timeout 300
-p 28967:28967/tcp
-p 28967:28967/udp
-e WALLET=“xxx”
-e EMAIL=“xxx”
-e ADDRESS=“xxx:28967”
–user $(id -u):$(id -g)
–mount type=bind,source=“/share/Storj/Identity”,destination=/app/identity
–mount type=bind,source=“/share/Storj/Storage/”,destination=/app/config
–name storagenode storjlabs/storagenode:latest