Backup on QNAP NAS [Tech Preview] - Testers Needed

The team just posted a guide on the Tardigrade documentation Backup on QNAP. Uses an Amazon S3 gateway + QNAP HBS 3 to do seamless backups for your QNAP. If you have a QNAP we would appreciate getting more usage and feedback in this thread.

I’m personally using it, and I think its one of the best integrations we have ever built (so far). We also have an upcoming app that will make the setup process even easier.

Sign Up:
Please sign up to be an official tester here.



I want to test. However my 55 $ coupon run out next month. Also when I tried to sign up I get an error

Mind resubmitting? I just deleted that question from the form. Will see what we can do in the way of test credit once you are officially sign up as a tester.

Now it worked to sign up.

Yesterday I’ve seen that there is a container for storj s3 gateway (found with search fonction of container station).
Is it possible to install the gateway this way (already tested, container ask me to choose the satellite then apikey, i’ve stop the test a this point) or only with ssh fonction as described in storj documentation?
I’ve sign up for testing.

We recommend you follow the documentation. If you use the container station manually there are some additional steps you have to take.

I tried it some time ago by myself and there it was HBS was not able to connect.
Will try again with proper manual.

The important step is changing the gateway address from to, which is covered by this guide. I spend a long time trying to figure out why it would not connect before we had this guide and instructions.

1 Like

I tried creating versioned backup, but that one fails. Just shows a popup saying system error. The docker container also does not show an error.
Normal backup seems to work.

EDIT: No I get an Error. Failed to utilize Snapshot

Mind creating a screenshot or video of what you an encountering?

Forgive me but I’m a complete user only - no dev skills at all but I can follow directions. I have a 1TB account with the Asia-East-1 Satellite and made a ‘test’ project a few months back but didn’t do anything more. I have followed the QNAP documentation yet when I get to the ‘Create a Backup Job’ in HBS3, I get the error message ‘Unable to use this bucket as the destination’. So I tried to create another bucket in the previous step - gives me the same error. When I go to my Tardigrade web account, I see that both buckets have been created so I have a connection.
Due to the fact I could see absolutely no way to create a new project or delete an existing one (how come I wonder) I also tried making another new account in the US-Central-1 Satellite and used uplink to create a bucket etc and upload a file. Yet same error message in QNAP when I try to create a backup job. I’m using the latest QNAP QTS software


A few observation in relation backup QNAP to Tardigrade:
First of all - it works - it is impressive!

That’s it for now… hope the above help - overall this is impressive!

Best, Michaël


Hello @michb,
Welcome to the forum!

Thank you for your feedback, we are appreciate it!
Please, let me clarify some of the mentioned issues.

Yes, it was added recently, I’ll create an issue on the Documentation board to update this. Thanks!

We uses docker image with a $(pwd)/gateway as a binding, so it can be any current directory, and this is not mandatory, so that’s why there is no any specific.
Can you share, what the current directory is usually available on your QNAP when you ssh to it?
What do you think, what is a best suited directory for the gateway config file?

It will print them every time when you start the gateway. Is it helpful?


Hi Alexey,

I created the gateway folder in /root - I believe - although that folder remains empty…

The access key / secret key were actually not printed for some reason when starting the gateway…

I rebooted the qnap - now tried restarting the docker - launches in the graphical docker interface - but seems to shut down again - same when trying from the command prompt (ssh) - still figuring out…

A post was split to a new topic: Error: gateway setup error: uplink: invalid access grant format