Bucket not loading

So yesterday I started using Storj DCS well more testing if I will use it in future, but I cannot access my buckets as lately I got this error:

I tried it on windows and IOS and tried Safari, Chrome, Edge, and Firefox
Non seem to work they error out after a few minutes.

Thanks

What is the satellite?
I tried on us2 and it’s working

It is Europe, because I’m testing it on live satellite to decide if we use it as a file share and backup system

I would not recommend to use a web browser as a client - it’s a server side encryption, not client side encryption.
Better to use uplink or rclone for the access, or at least FileZilla v3.51.0 with a native connector.

I’ll create a bug for the team regarding objects browser on EU1

So FileZilla is a different story
It doesn’t want to cooperate, I updated it to the latest version. I can download files but uploading files is issue.

The error look’s like this:

Error: upload failed: stream error: metainfo error: metainfo error: bucket name must contain only lowercase letters, numbers or hyphens
Error: File transfer failed
Status: Starting upload of C:\Users\Admin\Desktop\Cern\IMG_20191122_125551_BURST002.jpg
Status: Retrieving directory listing of /permanent/CERN…
Command: list /permanent/CERN
Command: put C:\Users\Admin\Desktop\Cern\IMG_20191122_125551_BURST002.jpg /permanent/CERN/IMG_20191122_125551_BURST002.jpg
Error: upload failed: stream error: metainfo error: metainfo error: bucket name must contain only lowercase letters, numbers or hyphens
Error: File transfer failed
Status: Retrieving directory listing of /permanent/CERN…
Status: Directory listing of /permanent/CERN successful
Status: Disconnected from server

It says issue with the bucket names but they are ok they are lower case letters only

So no idea why it is doing this

any suggestion?

It is still have a bugs. I would recommend to rollback it to 3.51.0, which is working perfectly.
I have created tasks for the team to contact FileZilla team to fix at least two known bugs related to prefixes (“subfolders”).
The downside of the old version of FileZilla - it doesn’t contain a new connector with access grants, so there is only deprecated one, it consumes satellite URL, API key and encryption phrase.
To create an API key (“access token”): Create Access Grant in CLI - Storj DCS

1 Like

Hey sorry to bother you but I’m getting this error from FileZilla

failed to parse access: uplink: node id is required in satelliteNodeURL
Error: Failed to retrieve directory listing

What should I enter for the satellite than , I’m not sure

Please, try europe-west-1.tardigrade.io and create an access token: Create Access Grant in CLI - Storj DCS, use it as an API key, specify your encryption phrase as a password.

1 Like

Need mo B.E.T.A T.E.S.T.I.N.G

stuff needs to work when released, better to give time much older
stable releases than unstable beta stuff.

costs in the larger picture, if people have a bad experience.

Yes this solved it for me thanks for the help

1 Like

FileZilla team is not a part of our team and they have an own development cycle. We can’t manage them.

The Objects browser should work though, so there is must be some issue with eu1 ones, because it is working on other satellites as expected.

4 Likes

I got a message from the team - the eu1 issue should be resolved now.
At least objects browser is working for me now.

3 Likes

good thing you are there to beat the filezilla team over the head with it then hehe
damn slackers :smiley:

Tickets from users would work better: https://trac.filezilla-project.org/

2 Likes

This might sound weird but when I open the buckets on the WEB UI. The uploaded files through FileZilla don’t seem to appear. is that normal?

Sounds like you are using different encryption passwords.

1 Like

no the same exact one, if we are talking about the word phrase.

You are using the same encryption phrase for Access Grant and object web file browser?

To be hones I don’t know.

I have just tried it: Created an Access Grant and used it in Filezilla to upload a file.
Then I entered the webGUI with the same encryption password and was able to see the file that I had just uploaded.