Bucket recovery

Soooooo I moved some files using Minio mc command line tool from Storj to Minio and for whatever reason, the files are broken on the Minio cluster. Maybe I used the wrong passphrase but because some work some don’t, I need to recover and redo.

Is there a way of recovering a bucket? Muppet here used mv not cp

It’s unlikely you used the wrong password as decryption will fail if the wrong password is used. If the files are gone, then they’re gone and there’s nothing that can be done.

The only thing is to confirm they really are gone: if you try to list a bucket with the wrong password it won’t show any files, so with the uplink command line you can try uplink ls --encrypted which skips decryption of the filenames and see if the files are still there with their encrypted names.

I’m happy to answer any more questions. Good luck!


Yes, I would suggest the same - please check the bucket without decryption, maybe your objects are still there. But you would have a different problem in this case - you would need to remember, what encryption phrase you have used when uploaded these objects to the Storj bucket.

But if you deleted a bucket too, then there is no way to recover it back, unless you did a server-side copy before moving/deletion, i.e.

uplink mb sj://mybucket-backup
uplink cp --recursive sj://my-bucket sj://mybucket-backup
1 Like

Thanks all so far. I didn’t delete the bucket so I tried the --encrypted command but got nothing back.

I connected to Storj using Minio mc CLI with S3 credentials, so its not like the objects might still be encrypted is it?

Weirdly some of the larger video files work but the photos don’t, I don’t see how that works, let me know if anything comes to mind.

I FIXED IT! (on the other side)

people, don’t use mv


In that case you had an access, so encryption phrase behind used s3 credentials was correct.

I’m glad to read, that you fixed an issue!
mv command could be safe, if the destination is reliable.