Can any one help me out i am facing this problem in windows shell os- win7

Can any one help me out i am facing this problem in windows shell os- win7.

I dont think windows 7 is supported.

Is there anything else you would suggest? Or any other idea?

You could try to download the identity file manually and running it that way, and seeing if you can run the node.

I havent tested on a windows 7 machine so im not even sure it can run a node but it wont hurt to try it.

I tried getting file from GitHub manually it doesnt work

Are you on windows 7 for any particular reason? You know you can update to windows 10 for free.

I have got dual core with 4 GB ram and I was looking for single node . It’s my first setup I am really not so good in computers but windows 7 runs very fine on dual core

If I try downloading win10 it’s a pain in the ass when it comes to update I have been through this when I use to have amd A10 laptop unless I upgraded with ssd

I understand, I will spin up a windows 7 VM and see if it will even run.

Just wanted to ask that is it possible if it is due to port forwarding issue I wanted to clear the doubt and I really appreciate your help.

Will get back to you going for nap

I just remember I visited some outside storj forum regarding the error -cannot convert null to type ""due to invalid enumeration. I get to know that the error is due to powershell version ( I might be wrong).

Installing windows 7 now Had to dig though all my achieves of ISOs…

Its for sure not supported I tested all ways to get working. So if this isnt your main system and not for everyday use you can install Ubuntu on it if you dont want to run windows 10. Thats really the only way you will be able to run a node.

1 Like

Dumb question but are you running it using administrative privileges’. Additionally you can create the identity somewhere else and just import it. I did that for most of my nodes

I was able to create an identity with windows 7
heres the screen shot of it running.

First thing I needed to do was make sure I was running a 64bit version of windows 7 and I download the identity file manually ran in administrator in powershell and it worked fine.

1 Like

no i am not using administrative privileges as they have clearly mentioned in their step

hi deadthlessdd ok i ll just update you after i try manually.