Can I use Docker pull image on tag of aarch64?

Hi Help,

I notice latest aarch64 (arm64/armv8) docker image ready in docker repo, that is great.

Can I use “docker pull storjlabs/storagenode:bc8a531-go1.12.9-aarch64” instead of “docker pull storjlabs/storagenode:arm”? If not now, when?


Hi Larry,

Our recommendation is to use storjlabs/storagenode:beta. Using alpha or arm will download the same image when using the same machine. They exist because of backward compatibility.

We have to update our documentation and removing the usage of arm tag for the ARM architecture.

Why you don’t have to choose the architecture?

Because we use a docker’s manifest (see A docker manifest defines a set of images which should be the same but adapted for different architectures, variants, etc. You can read a bit about that at

NOTE using other image tags is under your risk; those images are published in docker hub for internal purposes (testing, etc.), perhaps they will be a release but perhaps not.


Got it, thanks for clarification and script reminding.

using storjlabs/storagenode:beta does not work for me:

storj@pine64 : ~ $ docker pull storjlabs/storagenode:beta
beta: Pulling from storjlabs/storagenode
no matching manifest for unknown in the manifest list entries

Is there somewhere else that I can pull down the beta image?

What’s the output of uname -m? I am running Armbian on a 64bit aarch64 and it the beta tag worked for me.

storj@pine64 : ~ $ uname -m

Maybe a typo? I just tried it again and it worked for me. Good luck.

not for me… :frowning: