Can not delete empty bucket again

I have still the same problem that I cannot delete an empty bucket. Also not with force command.
Is there a force force command present? I just want to delete a bucket. However the bucket is empty

root@DESKTOP-M0C3J7T:~# aws s3 --endpoint= rb s3://backup --force
remove_bucket failed: s3://backup An error occurred (BucketNotEmpty) when calling the DeleteBucket operation: The bucket you tried to delete is not empty

What is version of Gateway?

Also, could you show result of the command:

aws s3 --endpoint= ls s3://backup/

@Alexey the bucket was definitely empty. However I can not give the output from s3 but there was no output due to bucket is empty. The version ist 1.1.8 running as a Docker container.

However with uplink cli it was possible to delete the bucket without any hacks.

This is why I wanted to see the result of the command
I know about this problem:

I would like to see the result of this command:

aws s3 --endpoint= ls s3://backup/ --recursive

Ah. Ok. I read third party tools. I can reproduce with FileZilla or QNAP will post output then

Ok @Alexey I reproduced it with a new bucket

  1. No output
    root@DESKTOP-M0C3J7T:~# aws s3 --endpoint= ls s3://duplicati --recursive

  2. Can not delete empty bucket
    root@DESKTOP-M0C3J7T:~# aws s3 --endpoint= rb s3://duplicati --force
    remove_bucket failed: s3://duplicati An error occurred (BucketNotEmpty) when calling the DeleteBucket operation: The bucket you tried to delete is not empty

  3. With uplink it works

jensamberg@DESKTOP-M0C3J7T:~ ./uplink rb sj://duplicati --force Bucket duplicati has been deleted jensamberg@DESKTOP-M0C3J7T:~

How to create such a bucket?

aws s3 --profile gateway --endpoint http://localhost:7777 mb s3://test324/
make_bucket: test324

aws s3 --profile gateway --endpoint http://localhost:7777 rb s3://test324 --force
remove_bucket: test324

Actuall I am not 100 % sure. However the last tests I did was:

  1. Create a duplicati Backup Task with S3 compatible gateway
  2. Using a docker container with gatway s3 version 1.1.8 running on QNAP x86 NAS
  3. Start the backup task and terminate it.
  4. Open Filezilla try to delete this bucket. Doesnt work. Filezilla says not empty.
  5. Try to delete via s3 and the gateway mention in point 2. Doesnt work
  6. Using uplink

I never run into any issue when I direct using gateway or uplink cli commands

Do you have something in the path option in the Duplicati?

what do you mean with path

By the way, have you tried a native Tardigrade option in Duplicati?

Yes. However it is to dangerous for me due to single password input. There is no double check of encryption password one typo and data is lost forever

You can use an access grant instead.

I can’t reproduce it :confused:

My systems have all German language.

Normally I avoid ä,ä,ü and so on. Shall it in general work using such kind of letters?

it’s new software… just don’t tempt faith unless if you are doing it to test… then good job :smiley:


@jensamberg Umlauts are supported as long as they supported by UTF8.
I used Russian names and they work normally.

However, I reported the problem to the team. Maybe something not merged into the Gateway code.
We have updated the libuplink and uplink to a new process to forcibly remove buckets (it’s useful when encryption phrase is lost)

1 Like

@jensamberg I cannot reproduce the issue with gateway v1.1.8.

aws s3 --endpoint=http://localhost:7777/ rb s3://backup --force

works for me just fine if I have a file in the backup bucket.

Are you sure you are running v1.1.8 on You can use the version command of gateway to check this.