Cannot access dashboard after power outage

I had a (self-caused) power outage yesterday and cannot access my node dashboard since. I am not sure if the node is running, but it seems to be. Here is what I have so far:
The node is running as a docker in Unraid, the same config has been working unchanged and stable for 4 months or so now.
Docker run command:

docker run
  -e TZ="Europe/Berlin"
  -e HOST_OS="Unraid"
  -e HOST_HOSTNAME="Tower"
  -e HOST_CONTAINERNAME="storagenode-v3"
  -e 'UDP_PORT_28967'='28967'
  -e 'TCP_PORT_28967'='28967'
  -e 'WALLET'='0xXXXXX'
  -e 'EMAIL'=''
  -e 'ADDRESS'='mydomain:28967'
  -e 'STORAGE'='6TB'
  -e 'TCP_PORT_14002'='14002'
  -e 'BANDWIDTH'=''
  -l net.unraid.docker.managed=dockerman
  -l net.unraid.docker.webui='http://[IP]:[PORT:14002]/'
  -l net.unraid.docker.icon=''
  --mount type=bind,source="/mnt/user/Storj/identity/storagenode//",destination=/app/identity
  --mount type=bind,source="/mnt/user/Storj//",destination=/app/config
  --restart unless-stopped 'storjlabs/storagenode:latest'

In the log I found some invalid configuration file key messages:

2023-04-11T10:19:10.425+0200    INFO    Invalid configuration file key  {"Process": "storagenode-updater", "Key": "storage.allocated-disk-space"}

Other than that it seems to be running:

2023-04-11T10:19:13.015+0200    INFO    Public server started on [::]:28967     {"Process": "storagenode"}
2023-04-11T10:19:13.015+0200    INFO    Private server started on        {"Process": "storagenode"}

I have tried adding the setup parameter again, I have tried restarting, I have double-checked the settings and port-forwarding, but to no avail.

I do not see any port mapping options in your docker run, please compare your command with the command from the documentation: Storage Node - Storj Node Operator Docs

Please never run the setup command for the worked node - you could destroy the node and it will be disqualified.

Thanks for the info regarding the SETUP. I was lacking other ideas so I tried that, but will not in the future.

While you are right that the port bindings do not show in the docker run command, I feel that this might be an Unraid specific topic. I can confirm, that the following port mappings are present (Unraid does offer a GUI to monitor forwarded ports):

May be, but your docker run command is missing it, so if you run it as a docker command, you must provide the port mapping.

I would not use the GUI to avoid misconfiguration.

However, if you are sure, that port mapping in place, you should see a dashboard anyway. If it’s not opening, there are two possible reasons:

  • port mapping is missed (and it’s missed in your docker run command)
  • node is not running

The second option you may check with two commands:

docker ps


docker logs --tail 20 storagenode

The last one is to show logs, and if your node is crashing, there should be a FATAL error.

Perhaps this should be more red:

Or event with a tick “I’ve read and understand this” before allowing to move on. Cause many folks seem to miss it :thinking:

Bright red, bigger fonts, and bold. Well, let’s be honest. When prospective node operators follow the host-a-node funnel, the second step before they get the auth token should be acknowledging that they understand what this message means. With an unskippable training video that lasts at least 5 minuntes, and a 10-question GPT-generated trick test that, if failed, blocks the user from getting the auth token for a day.