Cannot create bucket


I am trying to get the upload client to work. I have tried it on both Windows and Linux and have received the same challenge when trying to create my first bucket.

As you can see below, I am able to import the access grant but then I am unauthorized.

I created my project, created my access grant and granted all permissions possible (create bucket was not one of them). I received an access grant and then created a text file with the access grant in it. Nowhere do I see the option for an API key…but no matter what I do I am unable to create a bucket using the uplink cli. I believe the access grant I used in the text doc is the “serialized access grant”.

I tried saving it with just the serialized string, with



access: default

no format seems to result in me being allowed to create bucket with the uplink mb command.

Thanks for your help.

tomesd@Zazu:~/Downloads$ uplink import storj_access.txt
default access imported
tomesd@Zazu:~/Downloads$ uplink mb sj://tomesdata
Error: uplink: permission denied (bucket: metainfo error: Unauthorized API credentials)

I finally managed to create a bucket following the “continue in CLI” method discussed on this thread.