Cannot install GUI/ docker will not run

EDIT: still having issues with the gui software and docker container. also looks like my port is no longer open. hmm. I have it open in my router and windows firewall but i can’t access the port 28967. Cant figure out why lol. Would that be the cause of my issue?

getting an error when trying to install GUI - “There is a problem with this windows installer package”

so i tried running it in docker… but it keeps restarting and get this error - “Error: Error starting master database on storagenode: storage node database error: database satellites does not exist stat config/storage/satellites.db: no such file or directory”

i had my storage node up and running for almost 6 months as a docker container and one day it stopped working so i removed all docker related services and Docker itself. I then ran the GUI for about 6 months and all of a sudden it crashed. I had to format the drive that the data was on and there is no issues with the HDD.

With these issues my node gets disqualified so i have to start over with a new identity. This is getting pretty tiring as i will never get my payouts properly if this keeps up.

What can I do to get this to work? I’ve tried everything I can think of, any help would be appreciated.
Screenshot (2)

windows installer form 1.10.1 has some error, take previus verson 1.9.5, it will update itself after some time to latest.

do you use DDNS or you have fix ip? Id DDNS or noip servise, did you renew suscription every month? and insteled ip update software or setup router to update ip to ddns?

hi yes I use DDNS and it is all up to date. still trying to figure out why my system won’t port forward at the moment

provider closed ports? can you ping from outside your external ip?

hmm never thought of that. not sure how to ping from outside my external ip?

yes i can ping my IP from outside the network. still cant open any ports. Ive never had this before

Are you using latest binary ?

check you internal pc ip, if it on dhcp after restart it can change ip then, and forward ruul not work