Cannot open bucket created with the same encryption key


my .Net-Wrapper basically works. But if I create a bucket on Android (with my .Net-Wrapper, so the same coding) and try to open it on Windows, I get a “Could not open bucket - encryption error: decryption failed, check encryption key: cipher: message authentication failed”.
I’m using the same secret on Android and Windows and - as I’m using my .Net-wrapper with the same libuplink underneath - the same coding for encryption and decryption.

Any idea what could be the Problem?

Kind regards,


I’m assuming you can decrypt on Windows but you can’t decrypt on Android? I know with some ciphers (Usually with SSL) the clocks/dates need to be relatively close together for the ciphers to be in sync. Maybe check the date/time/region?

1 Like

True. It works on Windows but Not on Android. How to Check the dates? Do you mean it has to correspond with the Satellit Time zone/date/Region? Or with my Windows System?

Nice hint, though. Thanks!

The Windows and Android system would need to be using today’s date/time. For instance, if you built an Android system or restored a Windows VM that didn’t sync its clock, you might have one machine thinking it is 1-1-1900 and that can cause issues. I realize it’s just a shot in the dark and your devices are probably using the correct time, but it is something I’ve run into the past when I’ve worked with encrypted files between systems.

I don’t think the Satellite’s time would matter, since you can decrypt on Windows.

I found my error: on Android a space got Added to my secret through the Login-screen. So this was my fault.
Thanks for your help! It works now - I can open bucket created on all devices without Problems when I use the exact same secret.