Cannot run node on windows 10

“Statuses”: null,
“Help”: “To access Storagenode services, please use DRPC protocol!”,
“AllHealthy”: false

i have portforwad in router, applied rules in windows firewall too.
i see the service is running in windows but nothing is happening, what could be wrong?

i can confirm that GUI version of node for windows, works in windows 10 Pro.
but win10 is tricky, it may need more than 1 restart, and You need to harness the wild windows updater, who updates even if You say its not allowed at first. Almost all my problems with win10 was due to a updater stopping the network, because i did not wanted it to update for too long.
just my opinion: i would make sure win10 is updated enough and he don’t want more, before trying with node first start.

Check the log file.

Most of the time this is a port forwarding or public IP (or DynDNS) issue.

You may made a valid point. I am running windows 10 home. I had no luck on Ubuntu. And installed windows 10.

I will try Ubuntu server today and see if this will solve that issue.

Hello @shani81,
Welcome to the forum!

Please provide logs before re-installation (the root cause may be related to absence of a public IP, so the used OS will make no difference).

Is in win 10 gui or docker used?

I think the issue is on public ip.
here is my setup:
i have connected my computer from ISP-Router → network switch → computer
when i check my public ip it gives me aa.aa.aa.aa
when i check my ip4 it gives me 192.168.0.xx
i opened the port forward and done rules according to documentation on ip4
when i check online if port is open 28967 port it shows open on my pubilc ip aa.aa.aa.aa
ip4 it says port is closed
when i put my aa.aa.aa.aa port in router to open that the port it gives me error.

i am using win gui only

192.168.0.xxis your internal network IP, you need to make port forward from router to internal ip.
Also add you pc internl ip to leases in router, that router give your pc always same ip with dhcp.
Also you need open this port in windows firewall as inbound port.


The IPv4 on your PC will be from a private network, because your router uses NAT to give an internet to all your devices. You need to check your public IP on Open Port Check Tool - Test Port Forwarding on Your Router and compare it with the WAN IP on your router (usually on the Status page).
If they match - the port forwarding will work, otherwise you have several options:

  • call to your ISP and ask for a public IPv4, it may be a dynamic, must must be a public (WAN IP on your router will match the IP on yougetsignal). You may say that you need an access to your security IP Cam from anywhere to do not explain Storj to ISP’s staff;
  • switch to ISP who offer a public IP;
  • use VPN services with port forwarding option like, ngrok, PIA, AirVPN, PureVPN, etc.

i checked and compared it now.
it says port is open and has the same ip as on my WAN /router

but results are the same

maybe need to do everyting from scratch again?

While i was redoing everything i am getting this message - i got that on my first try too.

but the files are there in that location: %APPDATA%\Storj\Identity\storagenode

finally :slight_smile:

let us see if that really worked.

added no-ip address with port while installing the GUI-Windows and that worked.
thanks all for you quick and kind support really appriciate that.


looks like it is working fine now.

but i have another question.
i have an ubuntu server on same network with Xeon processor and 43TB Raid. what is the recommendation?
create a new setup with new idetities or can i reuse the same identities from my windows PC? how will be port forward setup? any ideas?

You must generate a new identity for the next node. If you would clone an identity, both will be disqualified pretty fast for losing data of each other.
Even if you would use a different authorization token for the same identity it will be still the same identity.
So, generate a new identity, sign it with a new authorization token and start the next node. Please note, the external port should be different.

I have seen that in two days my node has gone offline. What needs to be done to keep it alive.

System and internet is on 24/7.

Right now I am away from home and got email that node went offline.

Provide logs when home, then set up an teamviever at home and mobile phone.

also its in the storagenode.log file

I noticed that today it was electric meter changed in my building which caused 5-10 min electric cut off in whole building.
but sharing my log here.