Cant create an account

Sorry if this isn’tthe best place to post this issue. I’ve got a beta invite, but when I tried to create the account it said it would send an email to verify address, but it never did. This was maybe 6 hours ago. At this point, cant login and password reset doesnt work either. Also tried re-registering, but no luck.


1 Like

Beta developer invite? Make sure that you use Chrome or Firefox with all ad blockers disabled

have you checked your spam folder? have you whitelisted the address?

Mine went in the spam so check there

Same problem here.
Received the invite twice in a couple of weeks, but impossible to register.

Hello @deepiksdev,
Welcome to the forum!

What is the error?

@Alexey The error is can not register user

Please, could you provide a full error?
It should have an explanation

Are you trying to use the same token to register again?

When trying to register on the EU server I am told “This is an invite only alpha, please join the waiting list”. I am trying to register with the same email address as the invite was sent too.

You have to use the buttons provided in the email you received. The token to register with is passed through the url from that email.

A post was merged into an existing topic: Invited but not invited?

Yes I used the button provided within the email, just going to the site landing page will take you to a login page, not the sign up page, which is accessed via the embedded link. One complication is that the buttons in fact link via a third party called that is a mailshot management system. So maybe the data set at is not correct.