Cant edit config file


I cant edit my config file without storj saying that the key or the value of the key isnt right…

No problem witjout config

Tried to add logfile in config because docker env wouldnt take it either

Please specify wich file in wich environment with wich program did you try?

And what do you want to change and why?

Someone who knows docker will sure help you.

Its docker
Stopped docker, edited the file in cli
Started docker

When i start first node i must edit file to get it started.
Now if i edit file it doesnt start

What exactly you have changed and how?
Please note, any word processors, include macOS Notes, will corrupt the config file. You must use the plain text editors to do not break a config.

Just used nano in ubuntu

Tried to change log.output

But then comes with key invalid and couple value incorrect. Ex address not correct…
When I fill in the correct value, the error changes in incorrect key.

For the third time, what exactly did you try to write in the config. Paste the whole line in here.

My suspicion is, that you copy and paste from somewhere into the config.yaml and the double quotes are the wrong ones. Type them by yourself in the editor.

1 Like

log.output: “/app/logs/log.log”

log_output: /app/logs/log.log


log.output: "/app/logs/log.log"

Do you see the difference? Type the double quotes " by yourself and dont copy them from a word processor or a website.

Typed them by myself. But the file is empty… first time I had to change ex identity/.cert to /app/identity/.cert

What file is empty?
If you configured the log like this:

then log will be placed to that path inside the container, so you also need to bind some folder from the host to that path, i.e.

docker run -d .....\
--mount type="bind",source="/mnt/storj/storagenode/identity",destination=/app/identity \
--mount type="bind",source="/mnt/storj/storagenode",destination=/app/config \
--mount type="bind",source="/mnt/storj/storagenode/logs",destination=/app/logs \

or you may configure the log file like described in How do I redirect my logs to a file? - Storj Docs, then you wouldn’t bind another folder from the host, and log will be stored in the data folder.

actually it should be

# path to the certificate chain for this identity
identity.cert-path: identity/identity.cert

# path to the private key for this identity
identity.key-path: identity/identity.key

Weird with the identity it gave me an error last time if i did it lile that.

But nvm I just output the log with a docker command now but still strange that when I fill something in my node crashes…

Btw I already added the volume

It’s possible that you adding spaces before the option or uses a wrong one, like you mentioned earlier:

there is no such option. You can see available options with this command:

docker exec -it storagenode ./storagenode setup --help

By the way, you can use each option as a flag after the image name in your docker run command, i.e.

docker run -d ...\
--image storjlabs/storagenode:latest \