Can't get up linux node after reboot

Greeting,

I’m operating a CentOS node and I restart the system for maintenance reasons and I can’t get up again. I can’t access to dashboard so I check docker logs and I see this:

2020-05-16T12:07:04.923Z ERROR Invalid configuration. {"error": "invalid contact.external-address: lookup \"xxx.viewdns.net\" failed: lookup xxx.viewdns.net on 192.168.1.1:53: read udp 172.17.0.3:50251->192.168.1.1:53: read: no route to host", "errorVerbose": "invalid contact.external-address: lookup \"xxx.viewdns.net\" failed: lookup xxx.viewdns.net on 192.168.1.1:53: read udp 172.17.0.3:50251->192.168.1.1:53: read: no route to host\n\tstorj.io/storj/storagenode.(*Config).Verify:129\n\tmain.cmdRun:151\n\tstorj.io/private/process.cleanup.func1.4:344\n\tstorj.io/private/process.cleanup.func1:362\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:945\n\tgithub.com/spf13/cobra.(*Command).Execute:885\n\tstorj.io/private/process.ExecWithCustomConfig:86\n\tstorj.io/private/process.ExecCustomDebug:68\n\tmain.main:329\n\truntime.main:203"}

I don’t know what more to do, I really appreciate your suggestions.

Thank you.

I would start with some basic troubleshooting on your network.
Can you reach some basic Internet site?
Can you ping a site by IP address such as 8.8.8.8?
Can you ping a site by hostname such as dns.google.com?
Try from a PC on your network - if that succeeds try from your CentOS host.
The errors point to a DNS or router problem on either your network or your node.

Default configuration for many consumer routers is to have the router IP address set to 192.168.1.1 … if this is the case for your setup, then it looks like the error you have means that your Linux PC is unable to contact your local router.

However, it may also be a problem with your docker installation.

A little network addressing information would be helpful as well as docker version and docker run command you used…

The network setup is okay, at least as I know.

I tried all the things you suggest and go with no problems.

Any ideas?

It seems like a DNS resolution error, check out this link - the problem seemed to be a local firewall (iptables) configuration issue not allowing DNS lookups.

Thanks for you response.

Yes my router IP is set by default at 192.168.1.1 but CentOS contact it without problem.

It can be a docker problem as I don’t know too much about docker.

My docker version is 19.03.8 and docker run command is:
sudo docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967 -p 14002:14002 -e WALLET="xxxxxxxx" -e EMAIL="xxx@xxx.com" -e ADDRESS="xxx.viewdns.net:28967" -e STORAGE="800GB" --mount type=bind,source="/mnt/storj/homenode",destination=/app/identity --mount type=bind,source="/mnt/storj/storj",destination=/app/config --name homenode storjlabs/storagenode

I’m working with noip for static hostname and is working ok, I’m also working with a static internal IP for computer node and with 28967 TCP port opened, it had worked with no problem before the reboot.

Do you get a result from “nslookup xxx.viewdns.net”?

Yes, it works perfectly.

I configured the firewall when I prepared the node and I created a service with storj ports, I also checked it again and setting it like in the post you linked but I’m having the same error.

I don’t have any real experience with Docker outside of using it in Storj, reading the stack overflow thread might be of help, could it be that you have a Docker MAC conflict?

Thank you so much!!

I ran the container connected to host network and now work perfectly.

I only have to add --net host to run command.

Thank you again!

2 Likes