Cant open ports through a VPN

I have to use a VPN as some things on my local network don’t work. However, I cannot get ports to be viewed as open from a remote connection. I have my VPN port set as my external contact port then on my router I have the VPN port forwarded to the local port of the storj client. I followed the guide to setup through PIA but I am still confused.

Hello @CCTrollz,
Welcome to the forum!

Not everyone VPN will work. Only which have an ability to forward ports, such as PIA, portmap.io, ngrok, PureVPN, etc.
The other option - your own VPN server with a public IP.

Hi, I am using PIA which is what was used in the guide. I did have a remote VPN server however I am not experienced in network and couldn’t get it to function properly.

You should have:

  1. Port from the PIA
  2. The DDNS address
  3. The DDNS client on the same host with PIA.

You should specify the ADDRESS option in a format (example): your.ddns.net:45345, where the your.ddns.net is your DDNS address and 45345 is a port obtained from the PIA.
The same port should be allowed in your firewall (if you have one) as incoming.
The same port should be mapped to the 28967 in the -p PIA_port:28967 option of the docker run command, where PIA_port is your PIA port.

To change the parameter in your docker run command you should stop and remove the container, then run it back with all your parameters include changed ones.
To stop the container: docker stop -t 300 storagenode
To remove the container: docker rm storagenode
To run the container: https://documentation.storj.io/setup/cli/storage-node#running-the-storage-node

To check your port: https://www.yougetsignal.com/tools/open-ports/ , specify the DDNS address in the Remote Address field and PIA port in the Port field, then click Check.
If port is open - then you succeed.

No dice. Port still isn’t open. and Im using the GUI

In case of GUI you should also change the port in the server.address: option of the configuration file.
Please, use a Notepad++ to edit configuration file, do not use a regular Notepad.
The configuration file config.yaml is placed in the "%ProgramFiles%\Storj\Storage Node" by default.
Replace the default 28967 to the PIA port, the DDNS address with the PIA port should be placed to the kademlia.external-address: option.
Save the configuration file and restart the node, either from the Services applet or from the elevated powershell:

Restart-Service storagenode

just a notice commands:

Start-Service "Storage Node"
Stop-Service "Storage Node"
Restart-Service "Storage Node" 

Doesnt work (in power shell, windows 10/7 pro, 64bit)
whats work instead is for example:

Restart-Service “StorageNode”

so without space.

I got wrong instuctions from here, someone can change that if will:
https://documentation.storj.io/resources/frequently-asked-questions

2 Likes

Thank you!
The name of the service is fixed.

All fixed. Thanks Alexey!

1 Like