Cant' restart node can anyone help

I’m going to give it one more shot before I throw in the towel. I tried to start my node again and see this error: Error response from daemon: driver failed programming external connectivity on endpoint storagenode (e69d0856b7a2d100274d329dc030ac9af662e4abdfed9116930bd309b292172c): Error starting userland proxy: listen tcp 0.0.0.0:28967: bind: Only one usage of each socket address (protocol/network address/port) is normally permitted.
Error: failed to start containers: storagenode
I tried to stop then remove the node and then input the original string of info in the instructions but the error remains. Thanks in advance

Please, restart the Docker from the Docker desktop application in the system tray: click by right button on the icon of Docker and select Restart.

Thx. I restarted Docker and got this error, the string after “storagenode” is diffferent from the last time
Error response from daemon: driver failed programming external connectivity on endpoint storagenode (857b139655d33a4bea5f2e3f7c1542b716a9351212daf43a30e7ace76f360369): Error starting userland proxy: listen tcp 0.0.0.0:28967: bind: Only one usage of each socket address (protocol/network address/port) is normally permitted.
Error: failed to start containers: storagenode
Oh I typed docker PS and watchtower is still running if that helps at all

Then you should stop and remove the previous container:

docker stop -t 300 storagenode
docker rm storagenode

Then run a new one with all your parameters.

Thx but I tried that already. I just finished uninstalling the storj msi windows installation program and reinstalled it. It went through all the steps and set up fine but shows me as offline still

The Docker version must be not running, if you want to use the Windows service instead. You should choose either Windows service or Docker container.
In case of Windows service you must stop and remove the container and do not run it anymore.
Please, restart the “Storj V3 Storage Node” service from the Services applet after the docker container will be removed.
Then check your port on https://www.yougetsignal.com/tools/open-ports/

Ok so I stopped and removed the docker container stuff. I uninstalled the .msi file and reinstalled it using the IP assigned by my ISP on my router and the program installed without an issue. After installation I launched the webpage http://localhost:14002/ it shows me as offline. I checked whatismyip to be sure I used the correct one and the port open site yougetsignal.com which shows my port as open as well. So, it seems I set up everything correctly but still storj is down.

Please, open Powershell and show the output of commands:

(sls BEGIN $env:AppData\Storj\Identity\storagenode\ca.cert).count
(sls BEGIN $env:AppData\Storj\Identity\storagenode\identity.cert).count

The first one is: 2
The second one is: 3

Ok, your identity is signed.
Is your web dashboard still offline?
If so, then add the firewall exception. Run the powershell with administrator’s rights and execute:

New-NetFirewallRule -DisplayName "Storj v3" -Direction Inbound -Protocol TCP -LocalPort 28967 -Action allow

I appreciate all your help. I figured out what the issue was. I set up my router with a VPN and dynamic DDS service and for some reason Storj continued to work fine for a few days. When I disabled them Storj began working fine again. In any event if you’re super bored maybe you could tell me how to set up Storj with my VPN/Dynamic DNS service. This is what I had in the two segments where DNS/IP stuff is typed and was preventing Storj from functioning:

-p 28967:28967 -p 127.0.0.1:14002:14002
ADDRESS=“netgearddns.servermp3.com:28967
Thx

Not everyone VPN is working. Only those which could forward ports, like a SIA, portmap.io, ngrok, PureVPN, …
The different way - is own VPN server with a public IP.