Changelog v0.31.12

Important Storagenode Fix
v0.31.10 made it so that storage node will not accept more pieces if they are full. The used space calculation was still a bit wrong. v0.31.12 should fix the used space calculation. Again my apologies. Let us know if you have any issues.

7 Likes

In the next few minutes we will deploy the satellite with a new minimum storage node version. Please update your storage nodes because otherwise you will not get any uploads.

3 Likes

You guys are fast today!

3 Likes

Lets say we learned today a lot about which process we have to optimize and what is already working great.

3 Likes

Always good to learn something. Even though it might not always be pleasent.

own experience, is best teacher, take big price, but result is excellent.

Some new (to me) errors after the update to 0.31.12:

2020-01-30T20:30:38.630Z        ERROR   piecestore:cache        error getting current space used calculation:   {"error": "lstat config/storage/blobs/ukfu6bhbboxilvt7jrwlqk7y2tapb5d2r2tsmj2sjxvw5qaaaaaa/3v/}
2020-01-30T20:30:41.197Z        INFO    piecestore      download started        {"Piece ID": "NPAZAWHQ7DESYGVNACEQ5NVYCYLJ2FCGM4VCASMTMEYUGDFD3IFA", "Satellite ID": "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexM}
2020-01-30T20:30:46.139Z        INFO    piecestore      downloaded      {"Piece ID": "EWVJJRU3E5DLFAIL6GIESUJSMC3GRFGY5HP5IQVTL4Z7DNM4CQFA", "Satellite ID": "118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvv}
2020-01-30T20:30:47.106Z        ERROR   blobscache      newPiecesTotal < 0      {"newPiecesTotal": -329984}
2020-01-30T20:30:47.106Z        ERROR   blobscache      newPiecesContentSize < 0        {"newPiecesContentSize": -329472}
2020-01-30T20:30:47.106Z        ERROR   blobscache      newSatPiecesTotal < 0   {"newSatPiecesTotal": -329984}
2020-01-30T20:30:47.106Z        ERROR   blobscache      newSatPiecesContentSize < 0     {"newSatPiecesContentSize": -329472}

Anything to be worried about? Seems to be working fine otherwise.

Edit: Web dashboard and SNOboard shows incorrect disk space. Showing used space starting at zero when starting the node. Increases as uploads come in.

Updated and still no traffic on both nodes

There was used space calculation errors in the code. The current error displayed is to be expected. However, it would be concerning if it shows up again.

Storage Node with this version needs to recalculate the actual usage from scratch, hence it’s starting from 0 for the time being. Once it finishes the walking all the files it should show the correct usage.

3 Likes

Okay, thanks for the quick reply. I will let it run and see what happens. Maybe this info can be added to the the first post @littleskunk ?

1 Like

error: “out of space”, but dashboard shows space available. Anybody else seeing this?

have the uploads resumed, I’m v0.31.12 now for forty minutes now and my logs only get, get repair, put repair just curious

That one is an upload and it means everything is fine on your storage node.

ok great I was thinking plain put thanks

I’ve tried to do manual update with the instruction provided here but I’m still at 0.31.10

In order to manually update you need to remove the container and start a new container.

I think is what I did by following the provided instruction

I even try a few watchtower restart but it say a weird “Waiting for running update to be finished…” after the update to 0.31.10

Here the watchtower log

time="2020-01-30T19:21:55Z" level=info msg="Found new storjlabs/storagenode:arm image (sha256:d81cdf3ea58b88684029dfdd1b1eafb3154f2dcdf74ab918cbf0dc407dc93070)"
time="2020-01-30T19:21:57Z" level=info msg="Stopping /storagenode (c5a04eb40a2a7f7e1c8bb3712a59e293a0ebdde2b67614d235a16dd8955b344c) with SIGTERM"
time="2020-01-30T19:22:01Z" level=info msg="Creating /storagenode"
time="2020-01-30T23:02:22Z" level=info msg="Waiting for running update to be finished..."
time="2020-01-30T23:30:26Z" level=info msg="Waiting for running update to be finished..."

Yeah it doesnt update by restarting watchtower

My Windows GUI updated fine and quickly to 31.12 from 31.10.

My previous update to 31.10 had paused and didn’t automatically restart in windows 10.

This update restarted fine. It’s good if the windows 10 system can update clean and quickly with these rapid updates coming out

everythings seems normal in the logs after the update. my downloads continue.

I get uploads but they all fail with “context canceled” error on my Raspberry Pi node. I have 86% used space.

1 Like