Changelog v1.13.3

For Storage Nodes

Bug Fix for installing a node with existing data

We fixed the existing issue, that a storagenode operator was unable to (re-)install a node that already had data. With this release, this is now possible again.

Bug Fix for storagenode-updater

We improved the mechanisms to make the storagenode-updater more reliable and not keep updating itself continously or even failing to do so entirely.

For everyone that has an faulty storagenode-updater, please download the storagenode-updater binary manually from the above page and reinstall it.


someone can tel me why when we update to 1.13.3 we get 1.12.3 version? i checked in github under 1.13.3 version in inside is 1.12.3 version file.

1 Like



1 Like

First of all:
Please omit direct pings, especially when in extra messages…

I will double check which binaries have been uploaded.

Sory for that, but i do not know any other way that someone react fast. As it realy confusing situation,

Files have been reuploaded. It seems that @littleskunk just accidentially picked the wrong release folder.


Thank you for fast reaction.

No problem, thanks for reporting.
Next time, you might catch us quicker via DM in those emergencies.

eleven more days before I get to see the improved dashboard :upside_down_face:has anyone been able to update docker nodes as of 10/4/20


I updated mine, seems to work.

how long ago mine didn’t 8 hours ago just waiting on watchtower for now

3 hours ago. The raspi is still not updated.

tho i’m sure it’s fine since v1.13.1 was held back and ended up being 1.13.3, but ill wait a couple of days to see if there is any crying… i’m sure it’s fine tho
looking forward to the new features tho… so maybe take the plunge soon… :smiley:

My Docker Synology just updated but I had to recreate the container.
It got deleted :frowning:

That sounds like a problem with watchtower on your end. Can you take a look at it’s logs?

1 Like

wasn’t there something about watchtower needing to be updated when 1.13.1 was being rolled out or something like that…

I tried a manual update,docker pull storjlabs/storagenode:latest and this happened,latest: Pulling from storjlabs/storagenode
Digest: sha256:ec3cea868ce23fb2e528d5232aa2ed535c10ab8bd6b67151f5033c6df9319d25
Status: Image is up to date for storjlabs/storagenode:latest

watchtower may have already downloaded it but just not reinstalled the storagenode…
you will need to run a docker rm storagenode

and then your your run command
else the new version will not be applied… because docker has an image or whatever its called loaded into the storagenode instance / container its running, and only the run command will reload it from the new image…

you can see the image is on docker …

thanks after the docker pull I ran the docker run cmd and it was updated

1 Like

Does that mean I have to manually fix the 1.13.3 updater service so I can receive the 1.13.3 node update? Most of my nodes are still on 1.12.3 I think.