Changelog v1.47.3

For Storage Nodes

QUIC Status on Dashboard
The storage node is now checking UDP port forwarding by contacting a random satellite and requesting a UDP pingback. The result of that pingback will be shown on the storage node dashboard.

Multinode Add Node Command
The storage node info command is now returning the correct external address. The workaround from the last changelog is not needed anymore. The new command would be:

storagenode info --json --config-dir <insert your storage node config dir here> \
| multinode add --config-dir <insert your multinode config dir here> -

For Customers

You might notice a few segment limit commits. The segment limit hasn’t passed our final tests. We haven’t enabled the feature flag. Segment limits are still disabled.


Updated all 40 nodes, dont see any problem with quic so faar. Router only 1-3% cpu
So dont see any problem stated on quic in prerelise.


I ran the info command multiple times and every time it will display a different (new) API secret? Is it supposed that way? In that case “info” seems to be misleading. I would expect existing config to be displayed when using an “info” command.

Also I am not sure if I am doing that right as I get returned address and name empty and no port. So the info for entering into multinode seems incomplete.

Yes, it will.

I think it’s a bug specifically for the docker version (because there is no public address in the config.yaml, and this command is not aware about command line parameters and environment variables).
The name is expected to be empty for honestly, we cannot specify it anywhere except multinode dashboard.

1 Like

Is it assured it is working as expected? I tried the info command on 2 nodes today and was not able to add them to the multinode with the displayed api-secret. When i tried the same with the issue-apikey command, then adding to multinode was no problem.

Oooh, is that the issue. Well that’s easy to work around by simply adding --contact.external-address to the info command. (Obviously replace with your own domain/ip)

@jammerdan: I just confirmed that this works.
So full command should be

storagenode info --json --config-dir <storage node config dir> \
--contact.external-address <domain or ip>:<port> \
| multinode add --config-dir <multinode config dir> -

Did this appear today?
I checked when it updated and I didn’t see it. Did I just not see it?

Shift-F5 in your browser usually solves any visual issues.

That’s really neat. However what would really useful if the command would somehow fetch the ip and port and name from the docker run command by itself. But I don’t know if this can be ever achieved.

Well… it is set as an environment variable inside the container. But then substitution of variables happens outside the container so you can’t just use $ADDRESS in that command.


Oh, I know!

docker exec -it storagenode sh -c '/app/storagenode info --json --contact.external-address $ADDRESS --config-dir /app/config --identity-dir /app/identity'

:grinning: Wow. It is getting better and better!

1 Like

This is still relevant. I issued several api keys via the info command and spent half an hour trying to add the node to multinode and did not succeed.
Then I issued one single key via issue-apikey command and was able to instantly add the node to multinode.

Could you please submit a bug here: Issues · storj/storj · GitHub?