Connection Error to the Dashboard

Hello everyone,

I recently found out about this project and wanted to jump in. However; I cannot run a node because of some connection reasons that I couldn’t solve yet. I kindly ask for help from you guys.

I am sorry to share 3 different replies because of restrictions for the new users.

Hello @Noder ,
Welcome to the forum!

Please show the last 20 lines from your logs: How do I check my logs? | Storj Docs

1 Like

Hi @Noder
Can you see the WAN IP in the router? Does it match the 176.42.18.211 in the node settings? Or does the ddns.net name resolve to the correct IP?

Also the contact.external-address looks to be incorrectly formatted:
image

The first lines shows that either your DDNS updated to a wrong IP or port forwarding doesn’t work, or you do not have a public IP.

The last lines shows a network issue, your node cannot contact satellites and cannot resolve your DDNS hostname and it started to happen after you did something and restarted the node.

What should I write while installing the node program?

I tried with hostname:28967 and hostname alone

I could open the dashboard right now and reinstalled the node with the IP you see abow.

The entry in the config file should be either:

contact.external-address: IP:28967
or
contact.external-address: hostname:28967

You didn’t reply if the DDNS resolved IP is the same one as shown in your router.

Focus on getting TCP working, and then you can look to enable QUIC (UDP).

1 Like

in the node configuration the external address must be with port, so contact.external-address: hostname:28967, as @Stob said.

You really need to go to your router and search for WAN IP, if it’s not match the IP on Open Port Check Tool - Test Port Forwarding on Your Router, the port forwarding rule will not work.

1 Like

My WAN IP seen on no-IP is the same as the one on the “Open Port Check Tool”. I changed the config file as hostname:28967 and this is my port forwarding settings in the router. I am not an advanced tech guy so I am trying to understand first and then act as you guys say. I appreciate. Tool says the port is closed. :frowning:

No-ip of course will show the same IP as on yougetsignal. You need to open a Status page on your router to see a WAN IP (the IP from your ISP). You posted a port forwarding rule and it looks correct.
But the main point - if the WAN IP is different from your public IP, this is mean that your ISP placed you behind their NAT and your port forwarding rule will not work.

1 Like


Apparently, you are right about that. I have sent an email to my ISP to fix this. I appreciate for help!!

You have several options:

  • call to your ISP and ask for public IPv4, it could be dynamic, but must be a public (it will match the IP on yougetsignal). You can say that you need to have an access to your security IP cam from anywhere to do not explain Storj to ISP staff;
  • switch to other ISP who offer a public IP;
  • use VPN services with port forwarding option such as portmap.io, ngrok, PIA, AirVPN, PureVPN, etc.

I changed my mind and requested a static IP. Now WAN IP and External IP are the same. However; It seems the port is still closed. I called again ISP. They checked my router and they say the port is open for my security cam. But the tool says otherwise.

Make sure that your DDNS hostname is updated to the new IP. Or you can specify the static IP instead of DDNS hostname in the "C:\Program Files\Storj\Storage Node\config.yaml". If you do this, please save the config with menu File - Save (if you use a recommended Notepad++ editor, it will request administrators rights, you should confirm and repeat the saving), and restart your storagenode service either from the Services applet or from the elevated PowerShell:

Restart-Service storagenode

And also make sure that you have added firewall rules for both - TCP 28967 and UDP 28967 ports (in Windows Firewall they should be added as a two separate rules - for TCP and UDP to the inbound section only).

Config file is up to date. Firewall is set. Restarted the node. :frowning:

image


image
It is fixed!! Thank you very much Alexey and Stob!

2 Likes