Connection refused trying to view web dashboard

Hi
looking around I see a few of these but non have helped.
My RPI node appears to be up and running as the CLI dashboard shows online and data is being stored.-

Storage Node Dashboard ( Node Version: v1.95.1 )

======================

ID xxxxxxxxx
Status ONLINE
Uptime 2h39m6s

               Available        Used       Egress     Ingress
 Bandwidth           N/A     3.43 GB     93.16 MB     3.34 GB (since Mar 1)
      Disk       4.00 TB     3.33 GB

Internal 127.0.0.1:7778
External xxxxxx.duckdns.org:28967

I have changed the start cmd to -p 14002:14002.
if I use IP:28967 then it says about using the DRPC protocol
the node is on the home network, port 28967 is open, but from what I’ve read that is for satellite connection.
The Logs don’t show any errors.

I have run a node before and I was able to get to the web dashboard but that was a few years ago.
Any help is appreciated, and apologies for bringing this topic up again.
Mike

So when you point a browser to http://[IP_of_your_node]:14002 it says “connection refused”?

2 Likes

Yup thats the one

Are you sure your startup flags for port 14002 don’t still have a “127.0.0.1” somewhere in there? If your node is otherwise online… the most common reason not to see the GUI is that it’s only on the loopback address.

Can you do a “netstat -an | grep 14002”? You should see something like this:

tcp 0 0 0.0.0.0:14002 0.0.0.0:* LISTEN

1 Like

I believe so-
docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967/tcp
-p 28967:28967/udp
-p 14002:14002
-e WALLET=“xxxxxxxx”
-e EMAIL=“xxxxxxx.com
-e ADDRESS=“xxxxxx:28967”
-e STORAGE=“4TB”
–user $(id -u):$(id -g)
–mount type=bind,source=“/mnt/storj/Identity”,destination=/app/identity
–mount type=bind,source=“/mnt/storj/storagenode”,destination=/app/config
–name storagenode storjlabs/storagenode:latest

netstat -an ¦ grep 14002 gives -
tcp 0 0 127.0.0.1:14002 0.0.0.0:* LISTEN

where 14002 was in red?

This…

…doesn’t match this:

If your startup command really didn’t have 127.0.0.1 in it… then that section would be 0.0.0.0 like my example. Can you shut down the node and try starting it again?

Or… after you stopped it… run that netstat command again. If port 14002 is still showing as LISTEN… then something else is already on that port. Are you maybe running more than one node (and then need to put this one on 14003 or something)? Your flag would look like “-p 14003:14002” (so the inside port remains 14002, but it maps to 14003 on the outside

2 Likes

Cracking Roxor.

I’ve removed the image and rerun the startup command. Straight off it worked.

The original startup had the old -p 127.0.0.1:14002 in it.

Thank you for the help, mate

Mike

2 Likes