Container hangs

Hi there.
After setting up my node with the default provided information, I ran into the issue that my dashboard didn’t react after some time (about 6 hours +).
I am running the node on a dedicated 128GB RAM, 4 cores/8 threads xeon machine with ZFS and 30tb+ storage powered by a huge SSD l2ARC, up to date 19.04 ubuntu server - no other installations than what was was mentioned in the guideline.
Connectivity is 1 Gbps fiber unmetered with I believe a great peering.

Why does the system tell me I can post only two links as a new member?
It’s the reason anything now as a follow up is posted as a paste:
paste because the system didn’t let me post it…

So… what could it be and what could I provide more to investigate the issue?

My guess is that Ubuntu 19.04 is mostly the cause for this, Most of us went with 18.04 because its the most stable with docker, How long have you been running this node?

I never got it running for long as I just started out yesterday (Saturday, 21-09-2019).
It still would be weird for me as to why ubuntu 19.04 could be the cause as the docker images should come the same in the repository, with the difference on kernel improvements but those shouldn’t reflect issues with docker.

Sometimes an update to the kernel is all it takes to cause issues with different programs that havent been updated to supported it. Ive ran 18.04 since may with zero issues with crashing.

I looked at your docker command why are you running it this way “docker exec -it stora* genode /app/”

As per official guideline (end of the page) I should use it to have my " CLI Storage Node Dashboard" displayed.
It got malformed by copying as a pastee, my bad. So this is the exact command I run:

docker exec -it storagenode /app/

The dashboard works, just not after … roughly 6 hours when the container decides to just die.

which Docker version are you running?

Docker version: 19.03.2, build 6a30dfca0
Ubuntu: 19.04
Kernel: 5.0.0-29-generic x86_64
node: Storage Node Dashboard ( Node Version: v0.21.1 )

Dashboard when fresh booted

Storage Node Dashboard ( Node Version: v0.21.1 )


ID redacted
Last Contact 10s ago
Uptime 38s

               Available         Used     Egress      Ingress
 Bandwidth      324.0 TB       2.0 GB     1.6 GB     477.4 MB (since Sep 1)
      Disk       16.0 TB     346.5 MB

External redacted

Neighborhood Size 163

Im still going to say ubuntu 19.04 is causing issues if your node is crashing.

Which I accept but would like to know why. I can’t find any hints as to why.
I mean why bother packing it into docker if it’s possible to crash it after all when running it in a pretty much standard environment which is not resource constrained.

After all this is still in beta so I don’t expect a polished version and happy to provide more detailed logs and testing to improve the status quo.

Same reason they packed for windows and it always crashes
Ive tested both but I havent ran my node on ubuntu 19.04 yet cause if it aint broken dont fix it

I’m running an old : AMD E-350
Ubuntu server 19.04
Kernel : 5.0.0-29-generic x86_64
Docker : 18.09.7, build 2d0083d
Node Version : 0.21.1

Not had issues other than 19.04 not liking wifi, (that caused the server to loose internet connection randomly)

Only thing i can think of is the version of docker being used.
How did you install Docker?
You could try an earlier build of docker engine to see if the issue remains.