Could not rollup bandwidth usage - database is locked

I just did an integrity check on the info.db through sqlite3 (while I had my node temporarily offline), and it went ok, but after starting up the node, I see this error:

2019-09-07T12:10:06.914Z        ERROR   bandwidth       Could not rollup bandwidth usage        {"error": "bandwidthdb error: database is locked", "errorVerbose": "bandwidthdb error: database is locked\n\*bandwidthDB).Rollup:212\n\*Service).Rollup:51\n\*Cycle).Run:87\n\*Service).Run:43\n\*Peer).Run.func9:417\n\*Group).Go.func1:57"}

What’s going on here?

Hello @golyalpha,
Welcome to the forum!

Try to restart the node:

docker restart -t 300 storagenode

Make sure that you updated it to the latest version though

I’m using Watchtower to keep the node up-to-date (currently 0.20.1), so the version is fine. And I’ve already restarted the node when I’ve run the integrity check on the DB (had a similar error, hence why I ran it in the first place).

Edit: Just restarted the node though. Same error, and even the former error is showing (during “archiving orders”)

Also, I’m getting a few “untrusted peer” errors.

2019-09-07T12:20:30.692Z        ERROR   server  gRPC unary error response       {"error": "rpc error: code = PermissionDenied desc = untrusted peer 1QzDKGHDeyuRxbvZhcwHU3syxTYtU1jHy5duAKuPxja3XC8ttk"}

Not sure if that refers somehow to my node (node id is different), or if that’s some unofficial satellite running in the wild being refused by my node.

Thank you for that, what about the DB-related errors?

I don’t have a solution other then just wait when it will be resolved itself.
How long do you see this error, is the node running or restarting?

The node seems to be running mostly alright. There are download requests being received and served and the occasional context cancellation. I was also meaning to ask if there’s a way to store the DB somewhere other than alongside the data (on a faster but smaller storage medium, for example), since it’s now almost 1GB, and I can only image how slow the lookups are on the harddrive that way.

Such setups are possible, but not supported. Please, avoid them.