Create a bucket on the beta program

Last week I signed up for the Alpha for the S3 thing and was able to backup a test Discourse instance to a bucket I created (mostly following the Duplicati instructoins) and it worked like a charm.

Today I signed up for the Beta test (which I guess is a totally difeferent account?)

Do I need to use the CLI to create a bucket in the beta but in the alpha it just worked?

EDIT2: oh! I got s3cmd to work and it can see both of my buckets!! I’m back to being pretty excited.

EDIT: but then I used the access and secret keys that I created and it let me use the same bucket name that I used last week with the alpha program and then I just made up another name, and I pushed data there too.

So I don’t have to create a bucket with the cli? So maybe I should be using the AWS s3 CLI to create my buckets?

But the two buckets that I pushed data to don’t show up in the web interface, which still says “create your first bucket to get started”.

I’m quite confused.

This is depends on accounts which you used. All satellites are independent on each other, so you can create an account on US2 and have your own projects and bucket or create an account on any other satellite and have the same behavior.
You can use uplink CLI with an access grant from the satellite UI to create buckets and objects, also to manage shared access grants.
You can use AWS CLI to manage your buckets and objects if you have keys from Gateway-MT or self-hosted Tardigrade S3 Gateway.

Yes, it’s likely on US2 satellite.

Perhaps it’s a Vortex project and it’s a different account. There you would have a fixed bucket and have an access only to it.
You could also created an account on US-Central-1 satellite, then you can use it in the same way, as account from the US2, but they will not share your metainformation, so you would not see buckets created in US2 with access grant from the US-Central-1 and vice versa.

Well,l I don’t know what a vortex is, but I can imagine that is the explanation. :wink:

Ah. That makes sense.

I was able to see both buckets with s3cmd but neither of them showed in the web interface (which said I had no buckets), which I found disconcerting. But that too could have been a region/satellite issue. If there was a way to tell the web interface to look at a differentj . . . satelite? . . . I didn’t see it.


You can login to a different account in different tabs

There is no easy switch between them when you logged in, only logout and login or use different tabs. They works not exactly like zones in AWS, it’s independent servers. But with any of them you will have a multiregional storage by default (your data is distributed across the globe).

With s3cmd you likely have several profiles and can see content for each profile independently. For example, in case of you can have S3 keys, but cannot login to the satellite to see buckets, however, you can see content of the one bucket in Vortex.