Create an Identity On Synology NAS rpc ERROR

When I run identity authorize storagenode <your STORJ token > on my Synology NAS, it shows:
2022/10/24 23:29:20 proto: duplicate proto type registered: node.SigningRequest 2022/10/24 23:29:20 proto: duplicate proto type registered: node.SigningResponse 2022-10-24T23:29:20.443+0800 INFO Anonymized tracing enabled Error: rpc: tcp connector failed: rpc: dial tcp i/o timeout
I has DDNS for dymc ip. and I have closed firewall.

Hello @phoenix,
Welcome to the forum!

Something is blocking outgoing connections from your NAS. Please check firewall on your NAS and router.

But I have tried to telnet 8888 on google cloud’s Virtual machine instances, also can’t work.
how can I check the tcp connector working?

With identity authorize storagenode your-token-here command.

this command run log above. will occur rpc error :sleepy:

You may copy your identity to another device and try to authorize it there, then move signed identity back to Synology. However, you need to fix the underlaying problem with the network - you should not block outgoing connections.
May be your network interface on Synology have a wrong IP (for example - duplicated), or improperly configured.

I have solved it. Because my NAS can’t connect to “”. I use a network- proxy to run identity authorize storagenode.