Dashboard does not appear at all. White area on the browser

Hi Guys,

I have a problem with the dashboard. This does not appear at all. White area on the browser. No error message in the browser.
I have the GUI installed and this ran synonymous problems. On the plate is written. However, I can not really find out anything about it. I then reinstalled the software. Same problem. Completely deleted everything, new token requested. Reinstalled. Same problem. What’s wrong?

try deleting your browser cache or try a other browser

Hello @Snoopy1234,
Welcome to the forum!

Please, make sure that you do not running the docker and GUI versions in the same time. For the same storagenode you should use only the one method.

Please, try to use a Chrome or Firefox. Make sure that you have a JS enabled

1 Like

I’m also having this problem. Same deal no docker and tried on 3 different browsers, still blank.
I noticed this started happening 2 days ago.

1 Like

Try to clear the cache and cookies. Internet Explorer, Edge and Brave could not work properly, try to use Chrome or Firefox.

Hello,

I have the same problem but cleaning the cache/cookies does not bring the dashboard back. Any other solution ?

i have node version 0.26.2 for Windows
Tried rebooting, restarting both Storj services
No errors in the Storagenode.log file
Tried Edge, IE, Firefox, Chrome
The Dashboard worked fine for the first couple of days, then showed up in a “deterioated” way (Just text with no graphs), and then stopped showing at all, only blank page.

There is something in the source code of the page, like the page title “Node Dashboard”, but nothing else loads … :

Any help would be appreciated :slight_smile: Thanks in advance,

I use only Firefox and Chrome. I did what you suggested manually and no effect.
I even used CCleaner to erase cache and cookies for all browsers.
What next? Reinstall browsers?

try checkiing your sqlite dbs maybe one is broken.

https://support.storj.io/hc/en-us/articles/360029309111-How-to-fix-a-database-disk-image-is-malformed-

Hi. Which Windows version do you use? Problem was detected for EDGE and IE browsers (new EDGE based on Chromium works correct). Was tested with Windows 10. For EDGE browser is fixed and will be available ASAP.

1 Like

Hello and thanks for your reply.

I’m using Windows 10 Pro

Same here Windows 10 Pro

Hi Guys,
problem solved for me. It looks like the problem was Edge Explorer. Switch to Chrome and it works fine.

Thank you

Hi, still not solved for me, used firefox, chrome, ie, edge … same behavior on each browsers.

Don’t have any kind of errors in the log file. The node seems to run correctly (lots of uploads/downloads appearing in the logs), so frustrating that the dashboard doesn’t work :confused:

Hi, it looks like js is blocked. Can you open Dashboard in Chrome/Firefox, press F12 key and proceed to ‘Console’ tab? Are any messages there?

Hi,

Yes, there is this on chrome :
image

And the same kind of error on firefox (can’t post more than 1 image)

Interesting, I’m not seeing those errors on my end in Chrome.
Perhaps adding type="application/javascript" to the script tags would help.

I do not see such errors too. But it could be some extension

Do you have Pi-hole or ad blockers on?

It appears to be a feature in chrome that for protection it only executes .js files with mime type application/javascript, supposedly only when the header X-Content-Type-Options: nosniff is set. Maybe it’s enabled on new chrome versions even when this header is not set?

Source: https://stackoverflow.com/a/27267752/4833737
More info:
https://stackoverflow.com/questions/39228657/disable-chrome-strict-mime-type-checking
https://stackoverflow.com/questions/24528211/chrome-refuses-to-execute-an-ajax-script-due-to-wrong-mime-type