Delete blobs of europe-north-1 and us2?

# ./storagenode exit-satellite --identity-dir ./identity
2023-08-05T14:33:39Z	INFO	Anonymized tracing enabled	{"process": "storagenode"}
2023-08-05T14:33:39Z	INFO	Identity loaded.	{"process": "storagenode", "Node ID": "17s41dsY7PsVGRgkdwYuxkfKyv5o3ZDbu88UzfaihL1sE6S3Bm"}
By starting a graceful exit from a satellite, you will no longer receive new uploads from that satellite.
This action can not be undone.
Are you sure you want to continue? [y/n]
Domain Name                        Node ID                                              Space Used                  12tRQrMTWUWwzwGh18i7Fqs67kmdhH9t6aToeiwbo5mfS2rUmo   3.97 GB        1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE   0.72 TB                  121RTSDpyNZVcEU84Ticf2L1ntiuUimbWgfATz21tuvgk3vzoA6  561.02 GB                  12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S  2.26 TB                  12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs  2.69 TB  12rfG3sh9NCWiX3ivPjq2HtdLmbqCrvHVEzJubnzFzosMuawymB  111.64 GB   
Please enter a space delimited list of satellite domain names you would like to gracefully exit. Press enter to continue:
^C2023-08-05T14:33:51Z	INFO	Got a signal from the OS: "interrupt"	{"process": "storagenode"}

Is it safe to delete manually?


There will be no solution?
Can I remove these blobs?

US2 - arej6usf33ki2kukzd5v6xgry2tdr56g45pp3aao6llsaaaaaaaa
North - 6r2fgwqz3manwt4aogq343bfkh2n5vvg4ohqqgggrrunaaaaaaaa
Stefan? - abforhuxbzyd35blusvrifvdwmfx4hmocsva4vmpp3rgqaaaaaaa


I’ve got this same issue. Many of my nodes share several TB worth of data, stuck in old blobs folders. On the dashboard Suspension & Audit section, I see just the four now primary satellites, but still have all 6 Blobs folders.

Is the method below still the preferred way of cleaning up, @clement?

Yes, you may use this instruction to delete this data, just need to explicitly list satellites in the forget-satellite command

or explicitly add them to the untrusted list

and use the flag

To delete also blobs data you need to use the flag

Thank you for the clarification - this worked flawlessly for me :slight_smile:

1 Like