Denied access when creating a website

Hi guys. I try to create a static website with storj but I get a denied access.
On my Macos, I installed the uplink command and setup it on the satellite eu1.storj.io.
Then I uploaded my website via aws s3 because I need a recursive upload. The files are uploaded on storj, in my bucket.
So at this step, all works correctly.
Then I add a DNS storj site with the uplink share command.
I get the lines to add to my DNS provider. Especially I use the Access Key ID displayed in the output. Then on my DNS provider website (OVH), I configure the records manually and I displayed the textual version :

$TTL 3600
txt-www 3600 IN TXT “storj-access:XXX”
txt-www 3600 IN TXT “storj-root:site/src”
www 3600 IN CNAME link.eu1.storjshare.io.

The access key is the one displayed by the uplink command.
I uploaded my website in the bucket site and in the folder src.
The satellite is correct, it’s eu1.
I can’t see the $ORIGIN line but this textual configuration is displayed for the mywebsite dot blog website. So I guess it’s enough.
When I use the command “dig @1.1.1.1 txt-www dot mywebsite dot blog TXT”, I see the two txt-www dot mywebsite dot blog entries.
But I get a “Access denied” when I try to access to my website.
Do you have any idea what can be wrong?

1 Like

Hi @Bruno75,
If you try to access your link.eu1.storjshare.io/site/src/ folder in the browser does it work?

Hi @Bruno75,

Everything you wrote reads as correct steps to make it work. I’m not sure why it doesn’t work for you, but I’m happy to help! As @Stob has pointed out, it might be a good idea to do this sanity check by accessing the folder from the link.eu1.storjshare.io domain. One thing I would add to @Stob’s example is Access Key ID in the URL, i.e. https://link.eu1.storjshare.io/<Your-Access-Key-ID>/site/src/ (example: testbucket | Storj DCS). Let me know if that helps, and if it doesn’t, I’m here to help.

Thank you for using Storj DCS and Link Sharing Service!

2 Likes

Thank you !
I have the same error message “Access denied” with the URL : https://link.eu1.storjshare.io/jxtwcwzr26kn2nokbchza6iskk7a/site/src/
Once entered, the browser change the URL into :
https://link.eu1.storjshare.io/s/jxtwcwzr26kn2nokbchza6iskk7a/site/src/
It’s I used the access key displayed by the uplink share command.
If I use the access grant instead of the access key, a page is displayed to download or share the index.html file.
Perhaps I did a mistake at the level of the uplink setup ? I imagine there is a problem linked to the uplink share command ?
And I tried to refresh several times to reload the page. A message as “Object not found” has been displayed only once.
I checked the following command :
uplink cat sj://site/src/index.html
And it worked.

Could you please show your uplink share command?

I have checked:

./uplink share --dns custom.domain.tld --not-after +30m sj://web-test/src/
...
Remember to update the $ORIGIN with your domain name. You may also change the $TTL.
$ORIGIN example.com.
$TTL    3600
custom.domain.tld       IN      CNAME   link.us1.storjshare.io.
txt-custom.domain.tld   IN      TXT     storj-root:web-test/src
txt-custom.domain.tld   IN      TXT     storj-access:jvtj3vokviwx3l5prit7khjlfivq

I changed /s/ to /raw/ to show the “site” instead of object map

https://link.eu1.storjshare.io/raw/jvtj3vokviwx3l5prit7khjlfivq/web-test/src/
The link will expire 2021-07-29T20:36:00Z

It works ! This time it was because of the DNS delay I guess.
So I can start my new blog about crypto hosted on Storj. Great ! :slight_smile:
I guess it was a mistake at the uplink configuration. I had to delete it (/Users/XXX/Library/Application Support/Storj/Uplink/config.yaml on Macos) and run again the uplink commands.
Thank you !

3 Likes

It might not have been a mistake. You can configure the default access in the uplink, but then delete the access grant in the satellite UI, it’s become revoked almost instantly, so nothing derived with revoked access grant would work.

1 Like

Ok, thank you. So now my new blog (about crypto), based on Hexo is automatically built from a gitlab CI/CD when I update the markdown files in gitlab and is automatically deployed on Storj. Great ! My other blog based on the same technology (about DevOps) is deployed in the same way on AWS S3. So easy to migrate from AWS to Storj once the setup done ! :+1:

3 Likes

Would you like to share your blog URLs? If it’s not appropriate here you can also sent them via PM.