Did I get a bad drive from Amazon?

Maybe they got better after acquiring Samsung HDD department.

I do not know, but Samsung HDDs are in my personal “black-list” too - too slow and loud, the last one was a final brick (my home server was running on the living room that time).
From the durability perspective they was good enough (they survived after a one year always-on).

Samsung bought their HDD business from IBM. And IBM never ever had issues with HDDs until they released the famouse DTLA Telesto HDDs with glass disks.

I did not track the storage business for years now, but it’s good to know.
By the way, Toshiba is not my favorites too (too slow - 7600 is slower than WD Red (5400), how is it possible at all?!)

I don’t know much about internals of HDDs and how they operate, but browsing through specs, I see 2 main differences between manufacturers that I think can affect speeds: the recording technology and cache memory.
Toshiba uses Flux Control Microwave-assisted Magnetic Recording and Persistent Write Cache Technology in MG10 series (the enterprise level); maybe one of these or both make the drive slower.
I found a site with tests for many drives, and it seems MG10 is the slowest o the bunch, altough I don’t know how those tests apply to Storj usage pattern.
@Toyoo I think has done some tests with custom scripts that emulate storj drive usage. If he can share it to the community and make a simple “how to guide”, I can test Exos 16TB and 20TB, and other drives that I buy, and post the results. Maybe the community can participate also. @Vadim has MG10?

I have only MG06, MG07, MG09

Yeah, I need to decouple the scripts from my infra code, just didn’t have time for that yet. Recently got much busier, sorry!

I returned it for an Iron wolf Pro 16TB ($250).

The trasnfer rate is the roughly the same using rsync. Perhaps it’s because I am using an SBC? (Odyssey X86J).


Is clonezilla any better than just copying and pasting the partition in gparted? I have to take the node offline using either one right?

4c processor wouldn’t choke on simple data copy. Same for the SATA controller for single on-board port. Unless there is much more going on within the system - for what we know, you are running only your storagenode there. For the sanity check - what’s the CPU and RAM utilization when copying?

How are you connecting your disks? As mentioned there is only one on-board SATA port. Do you have the expansion card for it or are you connection through USB? If the latter, which USB adapter do you have? Do you have second one? Can you borrow to test?

Have you tried any other data transfer? Simple copy of a bunch of files, preferably a thousand of several kB each. Both not using rsync and not using storagenode data.

Have you tried the other way round - reading from the disk? What are the transfers then?

Do you have other machine to test the disk? Like, just plug it in and see how the transfers go.

That’s why I asked about your existing hardware. Going blind “oh, I must’ve been scammed” without evidence is… causing you unnecessary returns and trips to the store. Take it slow, test things, eliminate one by one to get to the culprit. Otherwise we are going to have a long thread here of you trying all the drives, SBCs, voodoo magic and stores there are.

All that said, try cloning if you just want to get over it. And yes, you need to take the node down - data needs to be not constantly changing while the cloning is happening.

CPU Usage is 45% to 65%

I didn’t check when I GPARTED the old drive to the new one but I’m zeroing out a drive right now and the CPU Usage is closer to 70-80%

5 nodes total 16TB/4TB/4TB/1TB/1TB are the drive sizes which is achieved using a 6 sata port M.2 2280 expansion card. There are 4 PCIe 3.0 Lanes on the M.2 port.

The other M.2. port has a 500BG SDD for the OS which is Ubuntu 22.0

RAM is usage is 3.2 GB out of 8 GB

NO USB’s used at all except the keyboard/mouse.

I get the same crummy transfer rate using either of the 2 open SATA ports (there is 1 left on the expansion card and 1 that is native to the SBC)

I’m 25W at the wall, BTW :slight_smile:

It’s all moot anyway. Using GPARTED I transferred 1 TB in a little under four hours. It’s worth it to have a node down for that amount of time to quickly and easily transfer the node to another device. That’s how I will handle transfers moving forward.

When I did Robocopy when I used to operate in windows the speed was much slower but it was still tolerable. I think it was like 700 GB/day. That was on a different machine though.

You are correct. To copy partition and have it consistent you need either unmount a source drive before copy or use snapshots (requires to use LVM or zfs or BTRFS (do not use BTRFS for storagenode though - it’s incredibly slow)).

i have one. works fine so far, fast as promised.

I have MG different versions, and i love them. Older versions go very slower when it go full. MG10 dont know yet, it is 20TB sot it not full yet by storj, but it filed also by chia and storj also use it, work fine, but all hdds that I have also use Promocache NVME cache.