Directory listing using Filezilla stopped working

Am getting the following error:

Error: Failed to retrieve directory listing
Status: Disconnected from server
Status: Connecting to
Status: Retrieving directory listing of /admin…
Command: list /admin
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

Am failing to debug this. Can you assist?

Hello @Barukimang ,
Welcome to the forum!

Could you please temporary connect via mobile network?

I suspect either your firewall or your ISP are blocking the outgoing traffic.

Hi @Barukimang
I think you may be using the incorrect connection details…


It will work with as well if you would use an Access grant instead of API Key + Password

It was working before, but then it stopped working. The settings have not been changed:

Because it looks to me as an ISP issue. Is it XFinity?

Issue solved!

Had the same issue using mobile network:


ISP has bandwidth of 130mb/ps so that is good.

Noticed that /admin file listing through the Storj dashboard also took more than 20 seconds, so adjusted timeout to ‘0’ infinity. That solved the issue.

1 Like