Docker doesn't work after system update

Hello, I just updated my Odroid HC2 with Debain, after restarting my Docker containers don’t run anymore, not even portainer, with which I manage everything. When I delete portainer and try to pull it again, I get the following error message:

Error response from daemon: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: unable to apply apparmor profile: apparmor failed to apply profile: write /proc/self/attr /exec: no such file or directory: unknown

How to fix the error? Unfortunately, Google couldn’t help me. All containers except Netdata are “exited”. I also tried to set up docker again, unfortunately without success. I hope you can help me. Thanks in advance.

1 Like

I ran into this issue with my asus tinkerboard basically they stopped adding the support into the kernal so you will need to add it yourself, Anyways I believe its the same thing that I had you can try it out to fix it…
Hmm it might not actually be the same issue going back to my config I had this error when trying to start docker.

Closest thing I could find on this error is this apparmor failed to apply profile: write /proc/self/attr/exec: invalid argument: unknown. · Issue #1199 · docker/for-linux · GitHub

Which you still need to add to the kernel.

I would recommend to uninstall docker and try the old one from the native Debian repository, may be it could start.
You may also try to upgrade your distro, if it’s outdated.

I have HC2 myself and in the past had node on it. I used Armbian Ubuntu based image.
Maybe try it if other solutions fail.

1 Like

I flashed my older backup on it, and got it running again, it was a little mess installing all other stuff which I installed since the backup. It’s now running again. Thank you for your help.

I also run my node on HC2 and was able to get it up and running again after downgrading docker to version 5:20.10.23~3-0~ubuntu-jammy.

1 Like