Docker: Drive has not been shared

While attempting to run the docker run command it errors out and says “Drive has not been shared”

In the docker app I went to “Shared Drives” and shared the root folder of the storage location and entered my login/password to my machine. I also tried sharing that folder in the windows share section of explorer as well. still no luck.

Hello @justifun,
Welcome to the forum!

Please, open the Docker desktop settings, clear selection from all drives, click the “Apply”. Select all drives, mentioned in your docker run command and click the “Apply” again
Then stop and remove the container and try to run it again.
To stop the container: docker stop -t 300 storagenode
To remove the container: docker rm storagenode
To run the container:

Make sure that your user is really have the password. The Windows will not allow you to share a drive without a password.

It should also ask you if you wan’t the drive to be shared on the bottom right corner after you do the docker run. Make sure you allow it to be shared.