Docker QNAP not working, wont start

Has anybody had any success on install docker container on qnap. I tried container wont start not sure if im missing configurations. what version should i use

Hi,
I‘m running 3 nodes successfully on my QNAP.
I am using Container station V 2.0.1189.

Are all your paths in the docker run command correct?

Im not that familiar with container station. I have it installed Im trying to figure out what commands do i need and where to input everything.

When you installed container station through the App Store, you basically have docker available. So when you connect to your QNAP with SSH you can use normal docker commands and start your Node with the command that is shown in the Storj documentation.

Dang never freaking thought of that. I was trying through container station gui. I’ll give it a shot. Thanks

1 Like

:slight_smile: The Container Station GUI is also a Little confusing to me. I didn‘t really use it…

real quick did you use the storj app in docker, i currently have it install should i uninstall it before continue with ssh.

You mean the STORJ QNAP app?
I am not using that because I run 3 nodes on the system, one with the internal drives and two nodes with two external drives. I think the Storj QNAP app only supports 1 node right now.

But as far as I know the Storj app is also just starting the docker container, so it should be more or less the same result as when you do it manually with the docker run command over ssh.

thanks for help. I got it running. problem i got now is i cant access dashboard.
docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-p 127.0.0.1:14002:14002 \

im trying to access dash from my computer. i can run the dashboard cli but not web version

Hmm that‘s strange. I don‘t have any idea what is causing this… I assume you are in the same network?

yea im on same network. are there other commands for the cli version

remove the 127.0.0.1: in the docker run command. To do that you need to stop and remove the container and run it back with all your parameters include changed ones.

this solved my issue back in May. I just removed my container and loaded the latest image again used the same settings but now i can’t get to dashboard. The container is up and running but no dashboard.

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-p 14002:14002
-e WALLET=“0xfB4FA4DfE8CCF83F15F29C5c093b97F6A145Ae10”
-e EMAIL="saywaah@protonmail.com"
-e ADDRESS=“annihilus.ddns.net:28967
-e STORAGE=“17TB”
–mount type=bind,source="/share/CACHEDEV1_DATA/homes/admin/Identity/storagenode",destination=/app/identity
–mount type=bind,source="/share/CACHEDEV1_DATA/Public/Storage",destination=/app/config
–name storagenode storjlabs/storagenode:latest

Please, check your logs:

docker logs --tail 20 storagenode